[PATCH v2 40/65] PicoJava: use is_whitespace()

Jan Beulich jbeulich@suse.com
Mon Jan 27 16:33:03 GMT 2025


Wherever blanks are permissible in input, tabs ought to be permissible,
too. This is particularly relevant when -f is passed to gas (alongside
appropriate input). Also convert ISSPACE(). At the same time use
is_end_of_stmt() instead of an open-coded check in adjacent code.
---
v2: New.

--- a/gas/config/tc-pj.c
+++ b/gas/config/tc-pj.c
@@ -236,13 +236,13 @@ md_assemble (char *str)
   int nlen = 0;
 
   /* Drop leading whitespace.  */
-  while (*str == ' ')
+  while (is_whitespace (*str))
     str++;
 
   /* Find the op code end.  */
   op_start = str;
   for (op_end = str;
-       *op_end && !is_end_of_line[*op_end & 0xff] && *op_end != ' ';
+       !is_end_of_stmt (*op_end) && !is_whitespace (*op_end);
        op_end++)
     nlen++;
 
@@ -301,7 +301,7 @@ md_assemble (char *str)
 	  pending_reloc = 0;
 	}
 
-      while (ISSPACE (*op_end))
+      while (is_whitespace (*op_end))
 	op_end++;
 
       if (*op_end != 0)



More information about the Binutils mailing list