[PATCH v2 39/65] PDP11: use is_whitespace()
Jan Beulich
jbeulich@suse.com
Mon Jan 27 16:32:36 GMT 2025
Convert open-coded checks.
---
v2: New.
--- a/gas/config/tc-pdp11.c
+++ b/gas/config/tc-pdp11.c
@@ -320,7 +320,7 @@ md_chars_to_number (unsigned char *con,
static char *
skip_whitespace (char *str)
{
- while (*str == ' ' || *str == '\t')
+ while (is_whitespace (*str))
str++;
return str;
}
@@ -328,7 +328,7 @@ skip_whitespace (char *str)
static char *
find_whitespace (char *str)
{
- while (*str != ' ' && *str != '\t' && *str != 0)
+ while (!is_whitespace (*str) && *str != 0)
str++;
return str;
}
More information about the Binutils
mailing list