[binutils-gdb] MIPS: use is_whitespace()
Jan Beulich
jbeulich@suse.com
Mon Feb 3 12:51:53 GMT 2025
On 03.02.2025 13:22, Maciej W. Rozycki wrote:
> On Mon, 3 Feb 2025, Jan Beulich via Binutils-cvs wrote:
>
>> commit 112cf77b1855f60a638543e06f6ce045d4231037
>> Author: Jan Beulich <jbeulich@suse.com>
>> Date: Mon Feb 3 12:07:21 2025 +0100
>>
>> MIPS: use is_whitespace()
>>
>> ... for consistency of recognition of what is deemed whitespace.
>>
>> At the same time use is_end_of_stmt() instead of an open-coded nul char
>> check, and check for statement end in the first place in
>> parse_relocation().
>
> Why hurry so much with this change? I've had a reply in the middle of
> being written with concerns about this change.
Well, such global changes easily go stale. It's not helpful to wait for
too long. Plus I have another somewhat similar set pending, which I'd
like to get out (and then soon-ish committed) as well.
And then - hurry? I've given it a week. Other changes are made without
even waiting a day.
In any event - please voice your concerns nevertheless. We can always
(partly) revert the changes made, especially as long as the final patch
of the series still didn't go in (which it didn't because the MMIX
maintainer had raised concerns there, and hence that patch didn't go in
either).
Jan
More information about the Binutils
mailing list