[gABI] Rename EM_INTEL205 to EM_INTELGT
H.J. Lu
hjl.tools@gmail.com
Fri Mar 19 12:55:35 GMT 2021
Rename EM_INTEL205 to EM_INTELGT for Intel Graphics Technology.
binutils/
* readelf.c (get_machine_name): Add EM_INTELGT.
include/
* elf/common.h (EM_INTEL205): Renamed to ...
(EM_INTELGT): This.
---
binutils/readelf.c | 1 +
include/elf/common.h | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/binutils/readelf.c b/binutils/readelf.c
index 9d7abac1bc5..cf628436678 100644
--- a/binutils/readelf.c
+++ b/binutils/readelf.c
@@ -2549,6 +2549,7 @@ get_machine_name (unsigned e_machine)
case EM_BA2: return "Beyond BA2 CPU architecture";
case EM_XCORE: return "XMOS xCORE processor family";
case EM_MCHP_PIC: return "Microchip 8-bit PIC(r) family";
+ case EM_INTELGT: return "Intel Graphics Technology";
/* 210 */
case EM_KM32: return "KM211 KM32 32-bit processor";
case EM_KMX32: return "KM211 KMX32 32-bit processor";
diff --git a/include/elf/common.h b/include/elf/common.h
index 015535a3039..241f2be167b 100644
--- a/include/elf/common.h
+++ b/include/elf/common.h
@@ -317,7 +317,7 @@
#define EM_BA2 202 /* Beyond BA2 CPU architecture */
#define EM_XCORE 203 /* XMOS xCORE processor family */
#define EM_MCHP_PIC 204 /* Microchip 8-bit PIC(r) family */
-#define EM_INTEL205 205 /* Reserved by Intel */
+#define EM_INTELGT 205 /* Intel Graphics Technology */
#define EM_INTEL206 206 /* Reserved by Intel */
#define EM_INTEL207 207 /* Reserved by Intel */
#define EM_INTEL208 208 /* Reserved by Intel */
--
2.30.2
More information about the Binutils
mailing list