V2 [PATCH] x86: Rename VexOpcode to OpcodePrefix

H.J. Lu hjl.tools@gmail.com
Wed Oct 14 02:21:03 GMT 2020


On Tue, Oct 13, 2020 at 2:49 PM H.J. Lu <hjl.tools@gmail.com> wrote:
>
> Rename VexOpcode to OpcodePrefix so that OpcodePrefix can be used for
> regular encoding prefix.
>
> gas/
>
>         * config/tc-i386.c (build_vex_prefix): Replace vexopcode with
>         opcodeprefix.
>         (build_evex_prefix): Likewise.
>         (is_any_vex_encoding): Don't check vexopcode.
>         (output_insn): Handle opcodeprefix.
>
> opcodes/
>
>         * i386-gen.c (opcode_modifiers): Replace VexOpcode with
>         OpcodePrefix.
>         * i386-opc.h (VexOpcode): Renamed to ...
>         (OpcodePrefix): This.
>         (PREFIX_NONE): New.
>         (PREFIX_F3): Likewise.
>         * i386-opc.tbl: Replace VexOpcode= with OpcodePrefix=.

This is the patch I am checking in.

gas/

* config/tc-i386.c (build_vex_prefix): Replace vexopcode with
opcodeprefix.
(build_evex_prefix): Likewise.
(is_any_vex_encoding): Don't check vexopcode.
(output_insn): Handle opcodeprefix.

opcodes/

* i386-gen.c (opcode_modifiers): Replace VexOpcode with
OpcodePrefix.
* i386-opc.h (VexOpcode): Renamed to ...
(OpcodePrefix): This.
(PREFIX_NONE): New.
(PREFIX_0X66): Likewise.
(PREFIX_0XF2): Likewise.
(PREFIX_0XF3): Likewise.
* i386-opc.tbl (Prefix_0X66): New.
(Prefix_0XF2): Likewise.
(Prefix_0XF3): Likewise.
Replace VexOpcode= with OpcodePrefix=.  Use Prefix_0X66 on xorpd.
Use Prefix_0XF3 on cvtdq2pd.  Use Prefix_0XF2 on cvtpd2dq.
* i386-tbl.h: Regenerated.


-- 
H.J.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-x86-Rename-VexOpcode-to-OpcodePrefix.patch.xz
Type: application/x-xz
Size: 35880 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20201013/7d0a4218/attachment-0001.xz>


More information about the Binutils mailing list