[PATCH] x86: Rename VexOpcode to OpcodePrefix

H.J. Lu hjl.tools@gmail.com
Tue Oct 13 21:49:06 GMT 2020


Rename VexOpcode to OpcodePrefix so that OpcodePrefix can be used for
regular encoding prefix.

gas/

	* config/tc-i386.c (build_vex_prefix): Replace vexopcode with
	opcodeprefix.
	(build_evex_prefix): Likewise.
	(is_any_vex_encoding): Don't check vexopcode.
	(output_insn): Handle opcodeprefix.

opcodes/

	* i386-gen.c (opcode_modifiers): Replace VexOpcode with
	OpcodePrefix.
	* i386-opc.h (VexOpcode): Renamed to ...
	(OpcodePrefix): This.
	(PREFIX_NONE): New.
	(PREFIX_F3): Likewise.
	* i386-opc.tbl: Replace VexOpcode= with OpcodePrefix=.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-x86-Rename-VexOpcode-to-OpcodePrefix.patch.xz
Type: application/x-xz
Size: 35404 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20201013/50576d93/attachment-0001.xz>


More information about the Binutils mailing list