V2 [PATCH] x86: Add {disp16} pseudo prefix
H.J. Lu
hjl.tools@gmail.com
Fri Jul 31 11:52:14 GMT 2020
On Fri, Jul 31, 2020 at 12:03 AM Jan Beulich <jbeulich@suse.com> wrote:
>
> On 30.07.2020 01:39, H.J. Lu wrote:
> > Here is the updated patch.
>
> Just one more thing: Wouldn't it make sense to mark {disp16} CpuNo64,
> at least as long as it's not usable for controlling branch displacements
> (which, as said, I think it shouldn't get enabled for)?
Since {disp16} can only be used for memory reference in 16-bit mode,
CpuNo64 isn't appropriate here.
--
H.J.
More information about the Binutils
mailing list