[PATCH 2/3] [aarch64] expose disas_aarch64_insn and rename it to aarch64_decode_insn
Marcus Shawcroft
marcus.shawcroft@gmail.com
Fri Oct 2 12:35:00 GMT 2015
On 2 October 2015 at 12:23, Yao Qi <qiyaoltc@gmail.com> wrote:
> include/opcode:
>
> 2015-10-02 Yao Qi <yao.qi@linaro.org>
>
> * aarch64.h (aarch64_decode_insn): Declare it.
>
> opcodes:
>
> 2015-10-02 Yao Qi <yao.qi@linaro.org>
>
> * aarch64-dis.c (disas_aarch64_insn): Remove static. Change
> argument insn type to aarch64_insn. Rename to ...
> (aarch64_decode_insn): ... it.
> (print_insn_aarch64_word): Caller updated.
> ---
> include/opcode/aarch64.h | 3 +++
> opcodes/aarch64-dis.c | 9 +++++----
> 2 files changed, 8 insertions(+), 4 deletions(-)
>
> diff --git a/include/opcode/aarch64.h b/include/opcode/aarch64.h
> index dcf0fef..d0c7489 100644
> --- a/include/opcode/aarch64.h
> +++ b/include/opcode/aarch64.h
> @@ -925,6 +925,9 @@ aarch64_stack_pointer_p (const aarch64_opnd_info *);
> extern
> int aarch64_zero_register_p (const aarch64_opnd_info *);
>
> +extern
> +int aarch64_decode_insn (aarch64_insn, aarch64_inst *);
The usual layout would be:
extern int
aarch64_decode_insn (....
OK with that change.
/Marcus
More information about the Binutils
mailing list