binutils/ld: mips linux build broken in latest -git head

Manuel Lauss manuel.lauss@gmail.com
Mon Dec 8 12:23:00 GMT 2014


On Mon, Dec 8, 2014 at 12:59 PM, Andrew Bennett
<Andrew.Bennett@imgtec.com> wrote:
>> Please have a look!
>
> Hi Manuel,
>
> Many thanks for reporting this issue.  I was wondering if you could
> provide me with the .config you are using along with the branch/git
> hash you are building from?

I build linus' latest -git kernels, with no patches, db1xxx_defconfig.

Gcc is gentoo's 4.9.2 patched to 4_9-branch from 05.12.2014.

# mipsel-softfloat-linux-gnu-gcc -v
Using built-in specs.
COLLECT_GCC=/usr/x86_64-pc-linux-gnu/mipsel-softfloat-linux-gnu/gcc-bin/4.9.2/mipsel-softfloat-linux-gnu-gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/mipsel-softfloat-linux-gnu/4.9.2/lto-wrapper
Target: mipsel-softfloat-linux-gnu
Configured with:
/tmp-ram/portage/cross-mipsel-softfloat-linux-gnu/gcc-4.9.2/work/gcc-4.9.2/configure
--host=x86_64-pc-linux-gnu --target=mipsel-softfloat-linux-gnu
--build=x86_64-pc-linux-gnu --prefix=/usr
--bindir=/usr/x86_64-pc-linux-gnu/mipsel-softfloat-linux-gnu/gcc-bin/4.9.2
--includedir=/usr/lib/gcc/mipsel-softfloat-linux-gnu/4.9.2/include
--datadir=/usr/share/gcc-data/mipsel-softfloat-linux-gnu/4.9.2
--mandir=/usr/share/gcc-data/mipsel-softfloat-linux-gnu/4.9.2/man
--infodir=/usr/share/gcc-data/mipsel-softfloat-linux-gnu/4.9.2/info
--with-gxx-include-dir=/usr/lib/gcc/mipsel-softfloat-linux-gnu/4.9.2/include/g++-v4
--with-python-dir=/share/gcc-data/mipsel-softfloat-linux-gnu/4.9.2/python
--enable-languages=c,c++ --enable-obsolete --enable-secureplt
--disable-werror --with-system-zlib --disable-nls
--enable-checking=release --with-bugurl=https://bugs.gentoo.org/
--with-pkgversion='Gentoo 4.9.2 p1.0' --enable-libstdcxx-time
--enable-poison-system-directories
--with-sysroot=/usr/mipsel-softfloat-linux-gnu --disable-bootstrap
--enable-__cxa_atexit --enable-clocale=gnu --disable-multilib
--disable-altivec --disable-fixed-point --with-float=soft --with-abi=
--disable-libgcj --enable-libgomp --disable-libmudflap
--disable-libssp --disable-libquadmath --enable-lto --with-cloog
--disable-isl-version-check --disable-libsanitizer --with-mips-plt
--with-arch=mips32 --with-tune=mips32 --with-llsc --with-float=soft
Thread model: posix
gcc version 4.9.2 (Gentoo 4.9.2 p1.0)


Thanks!
        Manuel



More information about the Binutils mailing list