[Patch, AArch64] change gas arch option name 'armv8' to 'armv8-a'
Yufeng Zhang
Yufeng.Zhang@arm.com
Mon Sep 17 16:53:00 GMT 2012
This needs to go into the 2.23 branch as well.
Thanks,
Yufeng
On 01/-10/37 20:59, Yufeng Zhang wrote:
> Hi,
>
> This patch updates the AArch64 gas -march option name from 'armv8' to
> 'armv8-a' to be in alignment with AArch64 gcc and 32-bit ARM binutils etc.
>
> Is it OK to commit?
>
> Thanks,
> Yufeng
>
>
>
> gas/
>
> 2012-09-17 Yufeng Zhang <yufeng.zhang@arm.com>
>
> * config/tc-aarch64.c (aarch64_archs): Rename 'armv8' to 'armv8-a'.
>
> gas/testsuite/
>
> 2012-09-17 Yufeng Zhang <yufeng.zhang@arm.com>
>
> * gas/aarch64/crypto.d (#as): Update.
> * gas/aarch64/int-insns.d (#as): Update.
> * gas/aarch64/legacy_reg_names.s (.arch): Update.
> * gas/aarch64/neon-not.s (.arch): Update.
> * gas/aarch64/neon-vfp-reglist-post.s (.arch): Update.
> * gas/aarch64/neon-vfp-reglist.s (.arch): Update.
More information about the Binutils
mailing list