[Patch, AArch64] change gas arch option name 'armv8' to 'armv8-a'

Yufeng Zhang Yufeng.Zhang@arm.com
Mon Sep 17 14:04:00 GMT 2012


Hi,

This patch updates the AArch64 gas -march option name from 'armv8' to 
'armv8-a' to be in alignment with AArch64 gcc and 32-bit ARM binutils etc.

Is it OK to commit?

Thanks,
Yufeng



gas/

2012-09-17  Yufeng Zhang  <yufeng.zhang@arm.com>

         * config/tc-aarch64.c (aarch64_archs): Rename 'armv8' to 'armv8-a'.

gas/testsuite/

2012-09-17  Yufeng Zhang  <yufeng.zhang@arm.com>

         * gas/aarch64/crypto.d (#as): Update.
         * gas/aarch64/int-insns.d (#as): Update.
         * gas/aarch64/legacy_reg_names.s (.arch): Update.
         * gas/aarch64/neon-not.s (.arch): Update.
         * gas/aarch64/neon-vfp-reglist-post.s (.arch): Update.
         * gas/aarch64/neon-vfp-reglist.s (.arch): Update.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: armv8-a.patch
Type: text/x-patch
Size: 2582 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20120917/53d28bd4/attachment.bin>


More information about the Binutils mailing list