Should rename ELFOSABI_LINUX into ELFOSABI_GNU, and drop ELFOSABI_HURD
Nick Clifton
nickc@redhat.com
Thu Jun 30 09:47:00 GMT 2011
Hi Samuel,
> 2011-06-19 Samuel Thibault <samuel.thibault@gnu.org>
>
> * elf.c (_bfd_elf_set_osabi): Use ELFOSABI_GNU name instead
> of ELFOSABI_LINUX alias.
> * elf32-hppa.c (elf32_hppa_object_p): Likewise.
> * elf64-hppa.c (elf32_hppa_object_p): Likewise.
>
> 2011-06-19 Samuel Thibault <samuel.thibault@gnu.org>
>
> * elfedit.c (osabis): Use ELFOSABI_GNU name instead
> of ELFOSABI_LINUX alias and ELFOSABI_HURD. Add GNU alias.
> * readelf.c (get_osabi_name): Likewise.
> (get_symbol_binding): Likewise.
> (get_symbol_type): Likewise.
>
> 2011-06-19 Samuel Thibault <samuel.thibault@gnu.org>
>
> * elfcpp.h (ELFOSABI): Add ELFOSABI_GNU with value of ELFOSABI_LINUX,
> keep ELFOSABI_LINUX as an alias. Remove ELFOSABI_HURD.
>
> 2011-06-19 Samuel Thibault <samuel.thibault@gnu.org>
>
> * config/obj-elf.c (obj_elf_type): Use ELFOSABI_GNU name instead
> of ELFOSABI_LINUX alias.
>
> 2011-06-19 Samuel Thibault <samuel.thibault@gnu.org>
>
> * common.h (ELFOSABI_GNU): Define, replaces...
> (ELFOSABI_LINUX): ... this, kept as an alias.
> (ELFOSABI_HURD): Remove.
Approved - please apply.
Cheers
Nick
More information about the Binutils
mailing list