Should rename ELFOSABI_LINUX into ELFOSABI_GNU, and drop ELFOSABI_HURD

Samuel Thibault samuel.thibault@ens-lyon.org
Fri Jun 24 23:13:00 GMT 2011


Samuel Thibault, le Sun 19 Jun 2011 22:32:24 +0200, a écrit :
> Forwarded from http://sourceware.org/bugzilla/show_bug.cgi?id=12913
> 
> Hello,
> 
> H.J. Lu added separate ELFOSABI_LINUX and _HURD definitions, but these
> are actually meant to be the same: the dynamic linker is the same in
> both cases, from glibc, with the same "GNU" extensions.
> 
> A recent change (http://sourceware.org/bugzilla/show_bug.cgi?id=10549)
> made this issue apparent eventually.  Roland says we should simply
> rename the existing ELFOSABI_LINUX into ELFOSABI_GNU, and remove
> ELFOSABI_HURD.  The attached patch does this (but keeps ELFOSABI_LINUX
> as an alias for software which may already be using it).

Ping?



More information about the Binutils mailing list