[patch]: ld set pseudo-relocation version 2 as default for x86 pe targets
Christopher Faylor
cgf-use-the-mailinglist-please@sourceware.org
Fri Nov 6 13:51:00 GMT 2009
On Fri, Nov 06, 2009 at 02:09:06PM +0100, Kai Tietz wrote:
>Hello,
>
>as now all x86 pe-coff runtimes are supporting in their startup code
>pseudo-relocation version 2, I would think it is time to change for
>them the default in pe.em.
>
>2009-11-06 Kai Tietz <kai.tietz@onevision.com>
>
> (USE_PSEUDO_RELOC): New macro.
> (gld_XXX_before_parse): Set pseudo-relocation default
> value to USE_PSEUDO_RELOC.
> (gldXXX_handle_option): Likewise.
>
>
>Tested for i686-pc-cygwin, i686-pc-mingw32, and i686-w64-mingw32. Ok for apply?
In theory, yes. I have a very minor nit with the name
"USE_PSEUDO_RELOC". It doesn't quite sound like what you're trying to
do to me. I think something like "PSEUDO_RELOC_VERSION" or "PSEUDO_RELOC_VAL"
might be better.
cgf
More information about the Binutils
mailing list