Failure building

Daniel Jacobowitz
Tue Nov 14 21:28:00 GMT 2006

On Tue, Nov 14, 2006 at 01:18:58PM -0800, Michael Eager wrote:
> I'm building insight-6.5 (latest, fixed download) on an older
> version Cygwin system which does not have makeinfo installed.
> The build fails attempting to build
> There seem to be several things which are not right.
> 1) The tarfile includes  There shouldn't be any need
>    to rebuild it.  (I even touched after untarring
>    to insure that make calculated the dependency correctly.)
> 2) There's a warning message that makeinfo is missing which
>    says that this would only be needed if a .texi or .texinfo
>    was modified.  None of these files were modified.

Same cause for these.  It probably rebuilt (or tried to) the generated
files produced by "chew".  Try touching those instead.

> 3) When the make decides that it needs to build, it
>    cd's to the SOURCE directory, creates a backup directory,
>    and moves, etc., to the backup directory.  It then
>    runs makeinfo, which fails, and it attempts to restore
>    from the backup directory.  Which doesn't appear to
>    happen.  It then deletes the backup directory and exits
>    with an error code.
>    Why is this building in the SOURCE directory?
>    This just seems to be the wrong thing to do.

Automake.  There's roughly nothing we can do about this code, I'm
afraid.  I've tried several times.

Daniel Jacobowitz

More information about the Binutils mailing list