[patch] Arm SMC instruction

Paul Brook paul@codesourcery.com
Thu Sep 8 03:15:00 GMT 2005


At the last minute ARM decided to rename the "SMI" (Secure Monitor Interrupt) 
instructions
 to "SMC" (Secure Monitor Call). The attached patch changes binutils to use 
the new name.

Tested with cross to arm-none-eabi.
Ok?

Paul

2005-09-08  Paul Brook  <paul@codesourcery.com>

bfd/
	* reloc.c: Rename BFD_RELOC_ARM_SMI to BFD_RELOC_ARM_SMC.
	* bfd-in2.h: Regenerate.
	* libbfd.h: Regenerate.
opcodes/
	* arm-dis.c (arm_opcodes, thumb32_opcodes): Rename smi to smc.
gas/
	* config/tc-arm.c (do_smi, do_t_smi): Rename ...
	(do_smc, do_t_smc): ... to this.
	(insns): Remane smi to smc.
	(md_apply_fix, tc_gen_reloc): Rename BFD_RELOC_ARM_SMI to
	BFD_RELOC_ARM_SMC.
gas/testsuite/
	* gas/arm/arch6zk.d: Rename smi to smc.
	* gas/arm/arch6zk.s: Ditto.
	* gas/arm/thumb32.d: Ditto.
	* gas/arm/thumb32.s: Ditto.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: patch.smc
Type: text/x-diff
Size: 7676 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20050908/b10bbd37/attachment.bin>


More information about the Binutils mailing list