include/ChangeLog vs include/*/ChangeLog

H. J. Lu hjl@lucon.org
Tue Apr 12 23:17:00 GMT 2005


Shouldn't the entry for */*.h be in include/*/ChangeLog? There are
quite a few:

	* opcode/m88k.h: Rename psr macros to avoid conflicts.
	* opcode/arm.h: Adjust comments for ARM_EXT_V4T and ARM_EXT_V5T.
	* opcode/crx.h (enum operand_type): Rename rbase_cst4 to rbase_dispu4.
	* opcode/crx.h (enum argtype): Rename types, remove unused types.
	* elf/arm.h: Add R_ARM_CALL and R_ARM_JUMP32.
	* opcode/crx.h (enum reg): Rearrange registers, remove 'ccfg' and `'pc'.
	* opcode/crx.h (operand_type): Remove redundant types i3, i4,
	* elf/arm.h (EF_ARM_EABI_VER4): Define.
	* elf/common.h (PT_SUNW_EH_FRAME): Define.
	* elf/x86-64.h (SHT_X86_64_UNWIND): Define.
	* elf/xtensa.h (R_XTENSA_DIFF8, R_XTENSA_DIFF16, R_XTENSA_DIFF32,
	* elf/arm.h: Remove R_ARM_STKCHK and R_ARM_THM_STKCHK.
	* elf/arm.h: Rename RELABS to TARGET1.
	* elf/common.h (PT_GNU_EH_FRAME, PT_GNU_STACK): Add comments.


H.J.



More information about the Binutils mailing list