Misc cleanups
Nathan Sidwell
nathan@codesourcery.com
Fri Feb 6 16:14:00 GMT 2004
Ian Lance Taylor wrote:
> Nathan Sidwell <nathan@codesourcery.com> writes:
> The code now assumes that TC_OPCODE_CASE is going to be defined, but
> nothing actually defines it. I know that the preprocessor doesn't
> require macros to be defined, but I don't personally like that
> approach.
>
> There are plenty of things in gas which require #ifdef. I think you
> should just invert the sense of IGNORE_OPCODE_CASE. Rename it to
> something like OPCODES_CASE_SENSITIVE, and test it with #ifdef.
sure. How about this one?
> Also the change to read_a_source_file() is OK, although I would be
> interested in hearing why those pseudos caused a problem.
There is no floating point, and there was a requirement that float
pseudos not exist. This seemed the most direct way.
I'll reply to your SKIP_ZEROES comments in another mail
--
Nathan Sidwell :: http://www.codesourcery.com :: CodeSourcery LLC
nathan@codesourcery.com :: http://www.planetfall.pwp.blueyonder.co.uk
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: d.diff
URL: <https://sourceware.org/pipermail/binutils/attachments/20040206/83187c54/attachment.ksh>
More information about the Binutils
mailing list