(FWD) Re: ** potential patch for 2.10 ** DEC Alpha bug relatedto AT register

Doug Rabson dfr@nlsystems.com
Wed Jun 7 11:28:00 GMT 2000


On 7 Jun 2000, Ian Lance Taylor wrote:

>    Date: Wed, 7 Jun 2000 09:18:07 +0100 (BST)
>    From: Doug Rabson <dfr@nlsystems.com>
> 
>    -	  if (!alpha_noat_on && num == AXP_REG_AT)
>    +	  if (!alpha_noat_on && (num + is_float) == AXP_REG_AT)
> 
> is_float is a terrible name for this variable, since the name implies
> a boolean value.  I believe the patch is correct.  If the variable
> were named something like regnum_offset or float_regnum_offset it
> would be clearly correct.

I agree about the naming but the intention with the patch was to minimise
changes.

-- 
Doug Rabson				Mail:  dfr@nlsystems.com
Nonlinear Systems Ltd.			Phone: +44 20 8442 9037




More information about the Binutils mailing list