(FWD) Re: ** potential patch for 2.10 ** DEC Alpha bug relatedto AT register

Ian Lance Taylor ian@zembu.com
Wed Jun 7 09:53:00 GMT 2000

   Date: Wed, 7 Jun 2000 09:18:07 +0100 (BST)
   From: Doug Rabson <dfr@nlsystems.com>

   -	  if (!alpha_noat_on && num == AXP_REG_AT)
   +	  if (!alpha_noat_on && (num + is_float) == AXP_REG_AT)

is_float is a terrible name for this variable, since the name implies
a boolean value.  I believe the patch is correct.  If the variable
were named something like regnum_offset or float_regnum_offset it
would be clearly correct.


More information about the Binutils mailing list