This is the mail archive of the
mailing list for the glibc project.
Re: [v2, with help] Re: run one test
- From: Carlos O'Donell <carlos at redhat dot com>
- To: DJ Delorie <dj at redhat dot com>
- Cc: Szabolcs dot Nagy at arm dot com, libc-alpha at sourceware dot org, nd at arm dot com
- Date: Mon, 30 Sep 2019 16:51:21 -0400
- Subject: Re: [v2, with help] Re: run one test
- References: <firstname.lastname@example.org>
On 9/30/19 3:58 PM, DJ Delorie wrote:
> "Carlos O'Donell" <email@example.com> writes:
>> Bikeshed. Suggest "onecheck" alias given that 'make test' is the same
>> as 'make check.'
> Can add. I was thinking we already have "make nss/tests" and "make
> tests", we call them "tests" and "testsuite", and "make check" is just a
> convenience target:
> # Support the GNU standard name for this target.
> .PHONY: check
> check: tests
> Or we could call it "make test" (note singular) but I suspect this would
> be confusing, and "make check" (note singular!) vs "make checks".
make check = make tests
make onecheck = make test
Or is the tests vs test too confusing?