This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Don't add nis subdir for new architectures


On Wed, 18 Jul 2018, Andreas Schwab wrote:

> On Jul 17 2018, Joseph Myers <joseph@codesourcery.com> wrote:
> 
> > On Wed, 4 Jul 2018, Andreas Schwab wrote:
> >
> >> +* Future architecture ports will no longer build a compatibility libnsl
> >> +  shared library, and --enable-obsolete-nsl will be ignored on those
> >> +  architectures.
> >
> >> +This option has no effect on architectures that were added after the
> >> +2.27 release.
> >
> > There's ambiguity here about new ABIs for existing architectures.  (Since 
> > they should be like new architectures regarding symbol versions, they 
> > should also be like new architectures in this regard.)
> 
> The intent is to exclude nis for all architectures and ABIs that have a
> base version of 2.28 or later.

Yes, I agree that's the right intent, but I'm not convinced it's clear 
from the documentation wording that e.g. RV32, or RV64 with 'F' ABI, would 
be a case where the option has no effect.

-- 
Joseph S. Myers
joseph@codesourcery.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]