This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Require binutils 2.25 or later to build glibc

On 06/28/2017 06:58 AM, Joseph Myers wrote:
> On Wed, 28 Jun 2017, Florian Weimer wrote:
>> On 06/20/2017 10:45 PM, Joseph Myers wrote:
>>> This patch implements a requirement of binutils >= 2.25 (up from 2.22)
>>> to build glibc.  Tests for 2.24 or later on x86_64 and s390 are
>>> removed.  It was already the case, as indicated by buildbot results,
>>> that 2.24 was too old for building tests for 32-bit x86 (produced
>>> internal linker errors linking elf/  I don't know
>>> if any configure tests for binutils features are obsolete given the
>>> increased version requirement.
>> Can we make 2.25.1 the minimum version?  Then we can drop the check in
>> sysdeps/arm/, too.
> I'm wary of testing for minor versions like that; it's entirely plausible 
> someone may have particular bug fixes from later on the release branch 
> without necessarily having the higher version number.

Are you suggesting you want to support a vendor "2.25" that has bug fixes
that has equivalent functionality to 2.25.1?

Why wouldn't such a vendor simply update to 2.25.1? Particularly if they
cared about ARM?

The upstream FSF versions have a very specific meaning. We should not be
confusing this with vendor branches and what they provide.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]