This is the mail archive of the
mailing list for the glibc project.
Re: Require binutils 2.25 or later to build glibc
On Wed, 28 Jun 2017, Florian Weimer wrote:
> On 06/20/2017 10:45 PM, Joseph Myers wrote:
> > This patch implements a requirement of binutils >= 2.25 (up from 2.22)
> > to build glibc. Tests for 2.24 or later on x86_64 and s390 are
> > removed. It was already the case, as indicated by buildbot results,
> > that 2.24 was too old for building tests for 32-bit x86 (produced
> > internal linker errors linking elf/tst-gnu2-tls1mod.so). I don't know
> > if any configure tests for binutils features are obsolete given the
> > increased version requirement.
> Can we make 2.25.1 the minimum version? Then we can drop the check in
> sysdeps/arm/configure.ac, too.
I'm wary of testing for minor versions like that; it's entirely plausible
someone may have particular bug fixes from later on the release branch
without necessarily having the higher version number.
Joseph S. Myers