This is the mail archive of the
mailing list for the binutils project.
Re: [PATCH] x86: Add .nop directive to assembler
>>> On 14.02.18 at 17:48, <firstname.lastname@example.org> wrote:
> On Wed, 14 Feb 2018, H.J. Lu wrote:
>> >> This requires much bigger changes. Also I like ".not SIZE, LIMIT".
>> >> But if everyone agrees that we should extend .skip, we can do that.
>> >> This may also remove the size limit.
>> > If I may chime in, it didn't occur to me before Jan mentioned it, but yes,
>> > I also think extending .fill feels more natural.
>> No, .fill isn't what we want.
> I fat-fingered that one, yes I meant .fill.
.fill again? Didn't you mean to write .skip this time?
>> We need to extend
>> .skip SIZE , FILL
>> So what should FILL look like?
> @nop, $nop, %nop? (I think only 'nop' without prefix would interact with
> uses in macros? The '@' prefix resembles a prefix for relocations, so
> that might be the natural choice). Perhaps also 'nop' should be 'anynop'
> or so, to indicate it's not just the single-byte 0x90 filler).
Having thought about this some more - since currently FILL is
expected to be an expression, none of the above is really suitable.
How about "nop" (including the quotes) instead?