This is the mail archive of the
mailing list for the binutils project.
Re: include/dis-asm.h patch for cgen disassemblers
- From: Andrew Cagney <ac131313 at cygnus dot com>
- To: "Frank Ch. Eigler" <fche at redhat dot com>
- Cc: Doug Evans <dje at transmeta dot com>, binutils at sources dot redhat dot com,cgen at sources dot redhat dot com
- Date: Fri, 01 Feb 2002 13:27:44 -0500
- Subject: Re: include/dis-asm.h patch for cgen disassemblers
- References: <20020131124350.C19966@redhat.com> <firstname.lastname@example.org> <20020131162132.I19966@redhat.com> <email@example.com> <20020201131309.C2190@redhat.com>
> Hi -
> dje wrote:
>> I recognize wanting to have a clear name ("isas"), but methinks for
>> the task at hand this just repeats the problem. The goal is (or was) to add
>> a target specific annotation to control disassembly.
> A general hook is the "char* disassembler_options" field, which is used
> as a catch-all. Where this field is used (arm, i386, ppc), it's almost
> exclusively to encode the ISA selection. I'd prefer to formalize the
> isa switch than continue to deformalize to a string option, especially
> as isa switching is a correctness issue. (Some of these disassembleres
> use the string also for rendering preferences.)
I would put it the other way round. Users use disassembler_options to
principaly do select assembly syntax and the like. They override the
>> At any rate, IMO this patch is better than the originally proposed patch.
> OK. Anyone with objections?
You mean like my constant questioning?