Bug 4310 - Hosts should auto refresh
Summary: Hosts should auto refresh
Status: RESOLVED DUPLICATE of bug 1788
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Unassigned
URL:
Keywords:
Depends on:
Blocks: 1788
  Show dependency treegraph
 
Reported: 2007-04-02 18:03 UTC by Phil Muldoon
Modified: 2007-04-02 19:32 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Muldoon 2007-04-02 18:03:31 UTC
Right now a user has to refresh a hosts inventory of Procs. They do this by
usually running the eventloop whenever they need a refresh or in a thread.
However on living systems the host really needs to refresh itself, to create
less of a burden on the user.
Comment 1 Andrew Cagney 2007-04-02 20:32:38 UTC
Marking as duplicate of bug #1788 - replace requestRefresh() with
Host.requestAddRefreshObserver.

Clients of the Host ask to be notified when something interesting happend and at
what frequency.  The host then internally if/when to schedule refresh updates
and notify all interested observers.

*** This bug has been marked as a duplicate of 1788 ***