Bug 28575 - binutils/readelf.c and binutils/strings.c use undefined type `uint'
Summary: binutils/readelf.c and binutils/strings.c use undefined type `uint'
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: binutils (show other bugs)
Version: 2.38
: P2 normal
Target Milestone: 2.38
Assignee: Alan Modra
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-10 09:29 UTC by Pekka Seppänen
Modified: 2021-11-10 17:56 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Replace `uint' by `unsigned int'. Apply line wrapping for `get_unicode_byte'. (1.25 KB, patch)
2021-11-10 09:29 UTC, Pekka Seppänen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pekka Seppänen 2021-11-10 09:29:28 UTC
Created attachment 13771 [details]
Replace `uint' by `unsigned int'.  Apply line wrapping for `get_unicode_byte'.

Hi.

Since --unicode support (commit b3aa80b45c4f46029efeb204bb9f2d2c4278a0e5) both binutils/readelf.c and binutils/strings.c use `uint' in a few locations.  It likely should be `unsigned int' since there isn't anything defining `uint' within binutils (besides zlib) and AFAIK it isn't a standard type.

Attached a patch.
Comment 1 Alan Modra 2021-11-10 10:02:15 UTC
Thanks, applied.