Bug 28083 - [x86-64] "wrssq %rax, %rax" causes an error, although it is a valid instruction
Summary: [x86-64] "wrssq %rax, %rax" causes an error, although it is a valid instruction
Status: RESOLVED NOTABUG
Alias: None
Product: binutils
Classification: Unclassified
Component: gas (show other bugs)
Version: 2.36.1
: P2 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-13 21:54 UTC by newdefectus
Modified: 2021-07-14 19:40 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description newdefectus 2021-07-13 21:54:53 UTC
Ditto for "wrssd %eax, %eax". According to the Intel docs, the first operand (second in AT&T syntax) is register or memory, however GAS only supports the operand being memory.
Comment 1 H.J. Lu 2021-07-14 14:35:56 UTC
It looks like an Intel SDM issue.  I am investigating it now.
Comment 2 H.J. Lu 2021-07-14 19:40:46 UTC
This is an Intel SDM issue and it will be fixed.  The destination operand
must be memory.