Bug 27983 - debuginfod client should eliminate duplicate outgoing server urls
Summary: debuginfod client should eliminate duplicate outgoing server urls
Status: RESOLVED FIXED
Alias: None
Product: elfutils
Classification: Unclassified
Component: debuginfod (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Noah Sanci
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-15 02:44 UTC by Frank Ch. Eigler
Modified: 2021-08-30 16:45 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Ch. Eigler 2021-06-15 02:44:08 UTC
Gazing at server logs, one sees a minority of clients who appear to have duplicate query traffic coming in: the same URL, milliseconds apart.  Chances are the user accidentally doubled her $DEBUGINFOD_URLS somehow, and the client library is dutifully asking the servers TWICE.  Bug #27863 reduces the pain on the servers' CPU, but dupe network traffic is still being paid.  We should reject sending outright duplicate concurrent traffic.
Comment 1 Frank Ch. Eigler 2021-08-30 16:45:38 UTC
commit 4c0491637c307e265677d643f3d80ed5f102306b
Author: Noah Sanci <nsanci@redhat.com>
Date:   Fri Jul 9 14:53:10 2021 -0400

    debuginfod: PR27983 - ignore duplicate urls