Bug 27873 - tst-cpu-features-cpuinfo fail when building on AMD cpu
Summary: tst-cpu-features-cpuinfo fail when building on AMD cpu
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: build (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: 2.34
Assignee: Adhemerval Zanella
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-16 07:34 UTC by Toolybird
Modified: 2021-07-15 03:39 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toolybird 2021-05-16 07:34:23 UTC
I'm seeing this failure when building on AMD Ryzen cpu:

Checking HAS_CPU_FEATURE (SSBD):
  HAS_CPU_FEATURE (SSBD): 0
  cpuinfo (ssbd): 1
 *** failure ***

It looks like H.J. provided a patch here:

https://sourceware.org/pipermail/libc-alpha/2021-January/122171.html

but it was never applied?

Thanks
Comment 1 Adhemerval Zanella 2021-06-28 18:08:06 UTC
Fixed on 2.34 (e3e3eb0a2ea615c272cec5f47ba9f243ccdaf386).