Bug 27750 - local variables have wrong address and values on sparc64
Summary: local variables have wrong address and values on sparc64
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: 10.1
: P2 normal
Target Milestone: 10.2
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-17 16:15 UTC by Dennis Clarke
Modified: 2021-04-19 13:29 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
foo_sparc64_gcc-9.xz made with gcc 9.3.0 (3.07 KB, application/octet-stream)
2021-04-17 17:55 UTC, Dennis Clarke
Details
foo_sparc64_gcc-10.xz made with gcc 10.2.1 (2.46 KB, application/octet-stream)
2021-04-17 17:56 UTC, Dennis Clarke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Clarke 2021-04-17 16:15:42 UTC
Possibly similar to 23220 however on 64-bit recent Debian sid with
trivial code I see : 

mimas$ 
mimas$ uname -a 
Linux mimas 5.10.0-6-sparc64 #1 Debian 5.10.28-1 (2021-04-09) sparc64 GNU/Linux
mimas$ 

mimas$ 
mimas$ /usr/bin/gcc --version 
gcc (Debian 10.2.1-6) 10.2.1 20210110
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

mimas$ 

mimas$ 
mimas$ cat -n foo.c 
     1
     2  #include <stdio.h>
     3  #include <stdlib.h>
     4
     5  int main(int argc, char **argv)
     6  {
     7      int a = 1;
     8
     9      printf("a = %i\n", a);
    10
    11      printf("&a = %p\n", &a);
    12
    13      return EXIT_SUCCESS;
    14
    15  }
    16
mimas$ 

mimas$ 
mimas$ /usr/bin/gcc -std=iso9899:1999 -pedantic -pedantic-errors -fno-builtin -g -m64 -O0 -mno-app-regs -mcpu=ultrasparc -mmemory-model=tso -o foo foo.c 
mimas$ 

mimas$ 
mimas$ TERM=dumb LC_ALL=C /usr/bin/gdb ./foo
GNU gdb (Debian 10.1-2) 10.1.90.20210103-git
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo...
(gdb) break 13
Breakpoint 1 at 0x858: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo 
a = 1
&a = 0x7fefffff5dc

Breakpoint 1, main (argc=0, argv=0x0) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print a
$1 = 0
(gdb) print &a
$2 = (int *) 0x7feffc5325b
(gdb) cont
Continuing.
[Inferior 1 (process 52994) exited normally]
(gdb) quit
mimas$ 

With a fresh local build of gdb 10.1 I see the same behavior : 

mimas$ 
mimas$ which gdb
/home/dclarke/local/bin/gdb
mimas$ 
mimas$ gdb --version 
GNU gdb (GDB) 10.1
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
mimas$ 

mimas$ TERM=dumb LC_ALL=C /home/dclarke/local/bin/gdb ./foo
GNU gdb (GDB) 10.1
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo...
(gdb) break 13
Breakpoint 1 at 0x858: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo 
a = 1
&a = 0x7fefffff5cc

Breakpoint 1, main (argc=0, argv=0x0) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print a
$1 = 0
(gdb) print &a
$2 = (int *) 0x7feffcf94ac
(gdb) cont
Continuing.
[Inferior 1 (process 52988) exited normally]
(gdb) quit
mimas$ 


-- 
Dennis Clarke
RISC-V/SPARC/PPC/ARM/CISC
UNIX and Linux spoken
GreyBeard and suspenders optional
Comment 1 Tom Tromey 2021-04-17 16:51:43 UTC
> Possibly similar to 23220 however on 64-bit recent Debian sid with

I looked at bug #23220, but that one uses stabs, so it's probably
unrelated.

Can you attach your executable?  That might provide enough info
to find the problem.

Frequently, though, this kind of thing turns out to be a compiler bug.
Comment 2 Dennis Clarke 2021-04-17 17:53:59 UTC
Seems like a good observation and I sort of wondered about the compiler
here. So then with gcc 9.3.0 from the Debian folks : 

mimas$ /usr/bin/sparc64-linux-gnu-gcc-9 --version 
sparc64-linux-gnu-gcc-9 (Debian 9.3.0-21) 9.3.0
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

mimas$ cat -n foo.c 
     1
     2  #include <stdio.h>
     3  #include <stdlib.h>
     4
     5  int main(int argc, char **argv)
     6  {
     7      int a = 1;
     8
     9      printf("a = %i\n", a);
    10
    11      printf("&a = %p\n", &a);
    12
    13      return EXIT_SUCCESS;
    14
    15  }
    16
mimas$ 

mimas$ /usr/bin/sparc64-linux-gnu-gcc-9 -std=iso9899:1999 \
> -pedantic -pedantic-errors -fno-builtin -g -m64 -O0 \
> -mno-app-regs -mcpu=ultrasparc -mmemory-model=tso \
> -o foo_gcc-9 foo.c 
mimas$ 
mimas$ which gdb
/home/dclarke/local/bin/gdb
mimas$ 
mimas$ TERM=dumb LC_ALL=C /home/dclarke/local/bin/gdb ./foo_gcc-9
GNU gdb (GDB) 10.1
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo_gcc-9...
(gdb) break foo.c:13
Breakpoint 1 at 0x878: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo_gcc-9 
a = 1
&a = 0x7fefffff5bc

Breakpoint 1, main (argc=0, argv=0x0) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print a
$1 = 0
(gdb) print &a 
$2 = (int *) 0x7feffa5d49c
(gdb) cont
Continuing.
[Inferior 1 (process 53214) exited normally]
(gdb) quit
mimas$ 

I will attach two binaries : 

    1) foo_sparc64_gcc-10.xz  made with gcc 10.2.1

    2) foo_sparc64_gcc-9.xz   made with gcc 9.3.0

I may go get sources to a previous gdb release and see if I can build
and test.

Thank you so much for your kind attention to this.
Comment 3 Dennis Clarke 2021-04-17 17:55:19 UTC
Created attachment 13375 [details]
foo_sparc64_gcc-9.xz   made with gcc 9.3.0

Compile flags : 

mimas$ /usr/bin/sparc64-linux-gnu-gcc-9 -std=iso9899:1999 \
> -pedantic -pedantic-errors -fno-builtin -g -m64 -O0 \
> -mno-app-regs -mcpu=ultrasparc -mmemory-model=tso \
> -o foo_gcc-9 foo.c
Comment 4 Dennis Clarke 2021-04-17 17:56:36 UTC
Created attachment 13376 [details]
foo_sparc64_gcc-10.xz  made with gcc 10.2.1

Same compiler flags as noted in the bug report.
Comment 5 Tom Tromey 2021-04-17 20:32:54 UTC
Another bit of info that might be useful is the output of
"info frame".
Comment 6 Dennis Clarke 2021-04-17 22:55:07 UTC

As a follow up I can report that gdb 8.3.1 seems to work as expected :

mimas$ which gdb 
/usr/local/bin/gdb
mimas$ 
mimas$ /usr/local/bin/gdb --version 
GNU gdb (GDB) 8.3.1
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
mimas$ 
mimas$ cat -n foo.c 
     1
     2  #include <stdio.h>
     3  #include <stdlib.h>
     4
     5  int main(int argc, char **argv)
     6  {
     7      int a = 1;
     8
     9      printf("a = %i\n", a);
    10
    11      printf("&a = %p\n", &a);
    12
    13      return EXIT_SUCCESS;
    14
    15  }
    16

Lets compile that with GCC 9.3.0 : 

mimas$ /usr/bin/sparc64-linux-gnu-gcc-9 -std=iso9899:1999 \
> -pedantic -pedantic-errors -fno-builtin -g -m64 -O0 \
> -mno-app-regs -mcpu=ultrasparc -mmemory-model=tso \
> -o foo_gcc-9 foo.c 
mimas$ 

mimas$ TERM=dumb LC_ALL=C /usr/local/bin/gdb ./foo_gcc-9 
GNU gdb (GDB) 8.3.1
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo_gcc-9...
(gdb) break foo.c:13
Breakpoint 1 at 0x878: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo_gcc-9 
a = 1
&a = 0x7fefffff5cc

Breakpoint 1, main (argc=1, argv=0x7fefffff978) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print a
$1 = 1
(gdb) print &a 
$2 = (int *) 0x7fefffff5cc
(gdb) cont 
Continuing.
[Inferior 1 (process 104230) exited normally]
(gdb) quit
mimas$ 

That all looks correct. 

Lets try again with gdb 10.1 from Debian : 

mimas$ 
mimas$ PATH=/usr/bin:/bin:/usr/sbin:/sbin ; export PATH 
mimas$ 
mimas$ which gcc
/usr/bin/gcc
mimas$ 
mimas$ uname -a 
Linux mimas 5.10.0-6-sparc64 #1 Debian 5.10.28-1 (2021-04-09) sparc64 GNU/Linux
mimas$ gcc --version 
gcc (Debian 10.2.1-6) 10.2.1 20210110
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

mimas$ gcc -std=iso9899:1999 \
> -pedantic -pedantic-errors -fno-builtin -g -m64 -O0 \
> -mno-app-regs -mcpu=ultrasparc -mmemory-model=tso \
> -o foo_gcc-10 foo.c
mimas$ 
mimas$ which gdb 
/usr/bin/gdb
mimas$ gdb --version 
GNU gdb (Debian 10.1-2) 10.1.90.20210103-git
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
mimas$ TERM=dumb LC_ALL=C /usr/bin/gdb ./foo_gcc-10
GNU gdb (Debian 10.1-2) 10.1.90.20210103-git
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo_gcc-10...
(gdb) break foo.c:13
Breakpoint 1 at 0x858: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo_gcc-10 
a = 1
&a = 0x7fefffff5fc

Breakpoint 1, main (argc=0, argv=0x0) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print a
$1 = 0
(gdb) print &a
$2 = (int *) 0x7feffd7727b
(gdb) info frame
Stack level 0, frame at 0x7feffd7727f:
 pc = 0x10000000858 in main (foo.c:13); saved pc = 0x7feffd76a88
 source language c.
 Arglist at 0x7feffd76a80, args: argc=0, argv=0x0
 Locals at 0x7feffd76a80, Previous frame's sp in fp
 Saved registers:
  l0 at 0x7feffd7727f, l1 at 0x7feffd77287, l2 at 0x7feffd7728f, l3 at 0x7feffd77297, l4 at 0x7feffd7729f, l5 at 0x7feffd772a7,
  l6 at 0x7feffd772af, l7 at 0x7feffd772b7, i0 at 0x7feffd772bf, i1 at 0x7feffd772c7, i2 at 0x7feffd772cf, i3 at 0x7feffd772d7,
  i4 at 0x7feffd772df, i5 at 0x7feffd772e7, fp at 0x7feffd772ef, i7 at 0x7feffd772f7
(gdb) cont
Continuing.
[Inferior 1 (process 104253) exited normally]
(gdb) quit
mimas$ 

Not sure how this compares to the gdb 8.3.1 : 

mimas$ 
mimas$ TERM=dumb LC_ALL=C /usr/local/bin/gdb ./foo_gcc-10
GNU gdb (GDB) 8.3.1
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo_gcc-10...
(gdb) break foo.c:13
Breakpoint 1 at 0x858: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo_gcc-10 
a = 1
&a = 0x7fefffff5fc

Breakpoint 1, main (argc=1, argv=0x7fefffff9a8) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print a
$1 = 1
(gdb) print &a
$2 = (int *) 0x7fefffff5fc
(gdb) info frame
Stack level 0, frame at 0x7fefffff600:
 pc = 0x10000000858 in main (foo.c:13); saved pc = 0xfffff8010014e804
 source language c.
 Arglist at 0x7fefffff600, args: argc=1, argv=0x7fefffff9a8
 Locals at 0x7fefffff600, Previous frame's sp in fp
 Saved registers:
  l0 at 0x7fefffff600, l1 at 0x7fefffff608, l2 at 0x7fefffff610, l3 at 0x7fefffff618, l4 at 0x7fefffff620, l5 at 0x7fefffff628,
  l6 at 0x7fefffff630, l7 at 0x7fefffff638, i0 at 0x7fefffff640, i1 at 0x7fefffff648, i2 at 0x7fefffff650, i3 at 0x7fefffff658,
  i4 at 0x7fefffff660, i5 at 0x7fefffff668, fp at 0x7fefffff670, i7 at 0x7fefffff678
(gdb) quit
A debugging session is active.

        Inferior 1 [process 104258] will be killed.

Quit anyway? (y or n) y
mimas$ 

Is there any other data I can get here ?
Comment 7 Simon Marchi 2021-04-18 01:21:32 UTC
Can you try with the latest gdb-10-branch (the soon-to-be GDB 10.2)?

https://sourceware.org/git/?p=binutils-gdb.git;a=shortlog;h=refs/heads/gdb-10-branch

I believe this is fixed there.
Comment 8 Tom Tromey 2021-04-18 01:57:44 UTC
(In reply to Simon Marchi from comment #7)
> Can you try with the latest gdb-10-branch (the soon-to-be GDB 10.2)?
> 
> https://sourceware.org/git/?p=binutils-gdb.git;a=shortlog;h=refs/heads/gdb-
> 10-branch
> 
> I believe this is fixed there.

It sounds like you have a theory of what the problem is... ?
If so it would be good to know, since I didn't recognize the problem.
Comment 9 Simon Marchi 2021-04-19 00:51:09 UTC
(In reply to Tom Tromey from comment #8)
> (In reply to Simon Marchi from comment #7)
> > Can you try with the latest gdb-10-branch (the soon-to-be GDB 10.2)?
> > 
> > https://sourceware.org/git/?p=binutils-gdb.git;a=shortlog;h=refs/heads/gdb-
> > 10-branch
> > 
> > I believe this is fixed there.
> 
> It sounds like you have a theory of what the problem is... ?
> If so it would be good to know, since I didn't recognize the problem.

Yes, sorry, I wrote that in a hurry.

I remembered fixing something for sparc, and indeed this commit fixes the bug reported by Dennis for me (before that commit, I see the bug):

gdb: set current thread in sparc_{fetch,collect}_inferior_registers (PR gdb/27147)
ffc17e2c029aea90166d16f5d49503c2c2e20982
Comment 10 Dennis Clarke 2021-04-19 10:44:29 UTC
I did checkout the gdb-10-branch and after a long and tedious build I
was surprised to see that "make install" seemed to actually install
nothing. That is a separate issue that I will figure out. 

However I can report that the behaviour seems sane :

mimas$ uname -a 
Linux mimas 5.10.0-6-sparc64 #1 Debian 5.10.28-1 (2021-04-09) sparc64 GNU/Linux
mimas$ cat /etc/debian_version 
11.0

mimas$ cat -n foo.c
     1
     2  #include <stdio.h>
     3  #include <stdlib.h>
     4
     5  int main(int argc, char **argv)
     6  {
     7      int a = 1;
     8
     9      printf("a = %i\n", a);
    10
    11      printf("&a = %p\n", &a);
    12
    13      return EXIT_SUCCESS;
    14
    15  }
    16

mimas$ /usr/bin/sparc64-linux-gnu-gcc-10 --version 
sparc64-linux-gnu-gcc-10 (Debian 10.2.1-6) 10.2.1 20210110
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

mimas$ /usr/bin/sparc64-linux-gnu-gcc-10 -std=iso9899:1999 \
> -pedantic -pedantic-errors -fno-builtin -g -m64 -O0 \
> -mno-app-regs -mcpu=ultrasparc -mmemory-model=tso \
> -o foo_gcc-10 foo.c
mimas$ 
mimas$ $HOME/local/build/binutils-gdb/gdb/gdb --version
GNU gdb (GDB) 10.1.90.20210419-git
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
mimas$ 
mimas$ TERM=dumb LC_ALL=C $HOME/local/build/binutils-gdb/gdb/gdb ./foo_gcc-10
GNU gdb (GDB) 10.1.90.20210419-git
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "sparc64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./foo_gcc-10...
(gdb) break foo.c:13
Breakpoint 1 at 0x858: file foo.c, line 13.
(gdb) run
Starting program: /home/dclarke/foo_gcc-10 
a = 1
&a = 0x7fefffff4fc

Breakpoint 1, main (argc=1, argv=0x7fefffff8a8) at foo.c:13
13          return EXIT_SUCCESS;
(gdb) print &a
$1 = (int *) 0x7fefffff4fc
(gdb) print a
$2 = 1
(gdb) info frame
Stack level 0, frame at 0x7fefffff500:
 pc = 0x10000000858 in main (foo.c:13); saved pc = 0xfffff8010014e804
 source language c.
 Arglist at 0x7fefffff500, args: argc=1, argv=0x7fefffff8a8
 Locals at 0x7fefffff500, Previous frame's sp in fp
 Saved registers:
  l0 at 0x7fefffff500, l1 at 0x7fefffff508, l2 at 0x7fefffff510, l3 at 0x7fefffff518,
  l4 at 0x7fefffff520, l5 at 0x7fefffff528, l6 at 0x7fefffff530, l7 at 0x7fefffff538,
  i0 at 0x7fefffff540, i1 at 0x7fefffff548, i2 at 0x7fefffff550, i3 at 0x7fefffff558,
  i4 at 0x7fefffff560, i5 at 0x7fefffff568, fp at 0x7fefffff570, i7 at 0x7fefffff578
(gdb) cont
Continuing.
[Inferior 1 (process 162221) exited normally]
(gdb) quit
mimas$ 

Seems valid. 

Why is the status of this bug "unconfirmed"? 

-- 
Dennis Clarke
RISC-V/SPARC/PPC/ARM/CISC
UNIX and Linux spoken
GreyBeard and suspenders optional
Comment 11 Tom Tromey 2021-04-19 13:29:04 UTC
(In reply to Dennis Clarke from comment #10)
> I did checkout the gdb-10-branch and after a long and tedious build I
> was surprised to see that "make install" seemed to actually install
> nothing. That is a separate issue that I will figure out. 

FWIW, this definitely works for me.

> However I can report that the behaviour seems sane :

Thank you.

> Why is the status of this bug "unconfirmed"? 

gdb as a project isn't too meticulous about tracking bug status.
Some people will change the status to "new", some won't.
I tend not to look at the unconfirmed/new difference when looking
at bugs, so I'm one of the guilty ones here.

Anyway, since this is reported as fixed, I am going to close it now.
That's one state we do track :-)

Thanks for your report & for building and trying out a newer gdb.