Bug 26451 - UBSAN error: bfd/som.c:4293:17:
Summary: UBSAN error: bfd/som.c:4293:17:
Status: RESOLVED DUPLICATE of bug 26452
Alias: None
Product: binutils
Classification: Unclassified
Component: binutils (show other bugs)
Version: 2.34
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-20 12:24 UTC by Martin Liska
Modified: 2020-08-26 08:37 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liska 2020-08-20 12:24:01 UTC
The following fails when I build binutils with:
configure --build=x86_64-linux --disable-nls --disable-gdb --disable-gdbserver --disable-sim --disable-readline --disable-libdecnumber --enable-obsolete --target=hppa-hp-hpux10 CFLAGS="-g -O2 -fsanitize=address,undefined -Wno-error" CXXLAGS="-g -O2 -fsanitize=address,undefined -Wno-error" LDFLAGS="-ldl"
Target: hppa-hp-hpux10
| 	exit( YY_EXIT_FAILURE );
Executing on host: sh -c {../as-new    /home/mliska/Programming/binutils/gas/testsuite/gas/all/p2425.s 2>&1}  /dev/null gas.out (timeout = 300)
/home/mliska/Programming/binutils/bfd/som.c:4293:17: runtime error: load of address 0x7fffffffbea0 with insufficient space for an object of type 'long unsigned int'
Comment 1 Alan Modra 2020-08-26 08:37:54 UTC
Dup

*** This bug has been marked as a duplicate of bug 26452 ***