Bug 26442 - UBSAN error: bfd/elf32-crx.c:512:21:
Summary: UBSAN error: bfd/elf32-crx.c:512:21:
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: binutils (show other bugs)
Version: 2.34
: P2 normal
Target Milestone: 2.36
Assignee: Alan Modra
URL:
Keywords:
: 26443 26444 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-20 12:21 UTC by Martin Liska
Modified: 2020-08-31 11:00 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed: 2020-08-30 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liska 2020-08-20 12:21:12 UTC
The following fails when I build binutils with:
configure --build=x86_64-linux --disable-nls --disable-gdb --disable-gdbserver --disable-sim --disable-readline --disable-libdecnumber --enable-obsolete --target=crx-elf CFLAGS="-g -O2 -fsanitize=address,undefined -Wno-error" CXXLAGS="-g -O2 -fsanitize=address,undefined -Wno-error" LDFLAGS="-ldl"
Target: crx-elf
| 	exit( YY_EXIT_FAILURE );
Executing on host: sh -c {./ld-new   -L/home/mliska/Programming/binutils/ld/testsuite/ld-crx  -T /home/mliska/Programming/binutils/ld/testsuite/ld-crx/crx.ld -o tmpdir/dump tmpdir/reloc-abs32.o  2>&1}  /dev/null dump.tmp (timeout = 300)
/home/mliska/Programming/binutils/bfd/elf32-crx.c:512:21: runtime error: left shift of 1 by 31 places cannot be represented in type 'int'
Comment 1 Alan Modra 2020-08-30 23:01:34 UTC
*** Bug 26443 has been marked as a duplicate of this bug. ***
Comment 2 Alan Modra 2020-08-30 23:01:50 UTC
*** Bug 26444 has been marked as a duplicate of this bug. ***
Comment 3 cvs-commit@gcc.gnu.org 2020-08-31 10:59:07 UTC
The master branch has been updated by Alan Modra <amodra@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=c1f138f9557a14678f6f988975cba441f56e6137

commit c1f138f9557a14678f6f988975cba441f56e6137
Author: Alan Modra <amodra@gmail.com>
Date:   Mon Aug 31 08:32:32 2020 +0930

    PR26442 UBSAN: elf32-crx.c:512 cannot be represented in int
    
            PR 26442
            * elf32-crx.c (crx_elf_final_link_relocate): Calculate reloc_bits
            without undefined behaviour.  Tidy excess casts.
Comment 4 Alan Modra 2020-08-31 11:00:57 UTC
Fixed