Bug 25576 - z80: [patch] Remove unnecessary local label definition
Summary: z80: [patch] Remove unnecessary local label definition
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: gas (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-19 10:40 UTC by Sergey Belyashov
Modified: 2020-02-19 17:50 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Remove unnecessary local label definition (806 bytes, patch)
2020-02-19 10:40 UTC, Sergey Belyashov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Belyashov 2020-02-19 10:40:37 UTC
Created attachment 12301 [details]
Remove unnecessary local label definition

I have missunderstood about local/global names. I think, that all non-local (which are identified by assembler or BFD) symbols are global.

This patch removes SDCC compatibility for:
- mark all non-global symbols prefixed by underscore as local.
- clear dollar-label cache after any non-dollar-label definition (cause test fail, because really local label is used in it - fixed).
Comment 1 Nick Clifton 2020-02-19 17:50:01 UTC
Patch applied