Bug 2522 - ca_ES@valencia: new Valencian (meridional Catalan) locale
Summary: ca_ES@valencia: new Valencian (meridional Catalan) locale
Status: RESOLVED FIXED
Alias: None
Product: glibc
Classification: Unclassified
Component: localedata (show other bugs)
Version: unspecified
: P2 enhancement
Target Milestone: 2.27
Assignee: Mike FABIAN
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-06 10:58 IST by Robert Millan
Modified: 2017-10-18 07:58 IST (History)
5 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
ca_ES@valencia locale (711 bytes, text/plain)
2006-04-06 10:59 IST, Robert Millan
Details
patch for localedata/SUPPORTED (246 bytes, patch)
2006-04-06 10:59 IST, Robert Millan
Details | Diff
update (249 bytes, patch)
2006-04-08 20:55 IST, Robert Millan
Details | Diff
ca_ES@valencia locale (707 bytes, text/plain)
2006-04-12 14:30 IST, Robert Millan
Details
ca_ES@valencia locale (714 bytes, text/plain)
2016-02-29 16:06 IST, Jordi Mallach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Millan 2006-04-06 10:58:34 IST
Valencian (meridional Catalan) locale for Spain with Euro

Note that this locale is almost the same as ca_ES@euro.  The point of having
a separate locale is only for PO translations, which have a lot of social
support and are very appreciated by the Valencian-speaking community.

Attaching ca_ES@valencia and supported.diff for the SUPPORTED file.
Comment 1 Robert Millan 2006-04-06 10:59:08 IST
Created attachment 952 [details]
ca_ES@valencia locale
Comment 2 Robert Millan 2006-04-06 10:59:35 IST
Created attachment 953 [details]
patch for localedata/SUPPORTED
Comment 3 Jordi Mallach 2006-04-08 11:38:32 IST
I have reviewed these changes and I think they are correct for our project to
provide Valencian translations.

If I remain as the contact for this locale, I would probably use my
jordi@gnu.org address though.

Thanks for submitting this, Robert.
Comment 4 Denis Barbier 2006-04-08 20:41:40 IST
Locale names are in the form 'language[_territory[.codeset]][@modifier]'
See glibc manual, node 'Using gettextized software'.
Thus UTF-8 variant should be called ca_ES.UTF-8@valencia
Comment 5 Robert Millan 2006-04-08 20:55:30 IST
Created attachment 961 [details]
update
Comment 6 Robert Millan 2006-04-08 20:56:13 IST
Oops.  Thanks for the pointer.
Comment 7 Robert Millan 2006-04-12 14:30:13 IST
Created attachment 966 [details]
ca_ES@valencia locale

-e s/debian.org/gnu.org/g -e s/meridional/southern/g
Comment 8 Ulrich Drepper 2006-04-26 02:02:31 IST
That's all bogus.  Adding locales is expensive.  If you want this kind of
support just create symlinks as part of a language pack.
Comment 9 Mike Frysinger 2011-09-19 20:45:46 IST
could you clarify where exactly the symlink would live ?

in terms of locale data, we can no longer do:
    /usr/lib/locale/ca_ES@valencia -> ca_ES
this is because now we have a locale archive, and that's a single file

the only place left where ca_ES lives is in /usr/share/i18n/locales/, and putting a symlink in there for ca_ES@valencia -> ca_ES has the same compile time costs as a dedicated file

there are people actually shipping ca@valencia message translations (GTK/GLIB to name a few), so clearly there is interest here
Comment 10 Jordi Mallach 2013-11-01 10:40:25 IST
Hello,

Can we revisit this?

Debian, Ubuntu and maybe some other distros have been carrying this locale as a patch for many years already, and I'd be happy to see it land on glibc.

If this is to be considered, I'd submit an updated locale definition.
Comment 11 Joan Montané 2013-12-18 09:18:19 IST
Just for info,

Debian and other distros support ca-ES@valencia locale.

Cooming LibreOffice 4.2 will suppport Valencian locale
https://wiki.documentfoundation.org/ReleaseNotes/4.2#Language_tag_support

CLDR has scheduled adding Valencian locale in 25 release (2Q 2014)
http://unicode.org/cldr/trac/ticket/6772

Several valencian translations (ca-ES@valencia) are provided to open-source projects. LibreOffice, Mozilla products, GNOME, KDE...

MS Windows 8 and 8.1 support Valencian locale (ca-ES-valencia) and provide language packs.
http://windows.microsoft.com/en-us/windows/language-packs#lptabs=win8

So, IMHO, It's time to add ca-ES@valencia locale here, :)
Comment 12 Jordi Mallach 2015-08-08 11:17:38 IST
Hi,

I'd like to do a final ping for this bug. It's been ages since most distros have been carrying this, and it would be really great to see it go upstream at long last.

Can I do anything to help move this forward?
Comment 13 Jordi Mallach 2016-02-29 16:06:35 IST
Created attachment 9053 [details]
ca_ES@valencia locale

This new version replaces the original locale file. Sole change is adding explicit "modification" rights to the licence, so it explicitly conforms to all free software rights.
Comment 14 Mike Frysinger 2016-04-15 17:56:58 IST
discussion/development has been moved to the mailing list:
  https://sourceware.org/ml/libc-alpha/2016-03/msg00615.html
Comment 15 cvs-commit@gcc.gnu.org 2017-10-17 15:08:34 IST
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU C Library master sources".

The branch, master has been updated
       via  5bf58bc75000e2f49a4836a53dcd2a43884469be (commit)
      from  386e1c26ac473d6863133ab9cbe3bbda16c15816 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=5bf58bc75000e2f49a4836a53dcd2a43884469be

commit 5bf58bc75000e2f49a4836a53dcd2a43884469be
Author: Aurelien Jarno <aurelien@aurel32.net>
Date:   Thu Jun 30 12:57:32 2016 +0200

    New locale ca_ES@valencia [BZ #2522]
    
    The Valencian (meridional Catalan) locale is basically a copy of the
    Catalan locale. The point of having a separate locale is only for PO
    translations. This locale is already provided by several distributions
    and is already supported by various projects like LibreOffice, Mozilla,
    Gnome, KDE.
    
    	Aurelien Jarno  <aurelien@aurel32.net>
    	[BZ #2522]
    	* localedata/locales/ca_ES@valencia: New file.
    	* localedata/SUPPORTED: Add ca_ES@valencia/UTF-8.

-----------------------------------------------------------------------

Summary of changes:
 ChangeLog                                         |    7 ++
 localedata/SUPPORTED                              |    1 +
 localedata/locales/{ca_ES@euro => ca_ES@valencia} |   80 ++++++++++-----------
 3 files changed, 47 insertions(+), 41 deletions(-)
 copy localedata/locales/{ca_ES@euro => ca_ES@valencia} (52%)
Comment 16 joseph@codesourcery.com 2017-10-17 16:38:33 IST
If the commit fixes the bug, please mark it as FIXED with the target 
milestone set to 2.27.
Comment 17 Mike FABIAN 2017-10-18 07:58:46 IST
Fixed in glibc master.