Bug 25171 - build failure after 'git clone' and after 'make distclean'
Summary: build failure after 'git clone' and after 'make distclean'
Status: RESOLVED DUPLICATE of bug 24729
Alias: None
Product: gdb
Classification: Unclassified
Component: build (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-07 11:56 UTC by Tim Rühsen
Modified: 2019-12-18 15:14 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed: 2019-12-18 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Rühsen 2019-11-07 11:56:12 UTC
after cloning the repo or after 'make distclean', a './configure && make' stops with:

+++
configure: error: source directory already configured; run "make distclean" there first
configure: error: .././../../gnulib/configure failed for build-gnulib-gdbserver
configure: error: ./configure failed for gdbserver
make[1]: *** [Makefile:10828: configure-gdb] Error 1
make[1]: Leaving directory '/home/oms/src/binutils-gdb'
make: *** [Makefile:852: all] Error 2
+++

A second 'make' then continues and succeeds.

IMO, it should either be fixed or documented in README.

'make' is aliased to 'make -j12'.

OS is Debian unstable (upgrade from 07-11-2019)
make           4.2.1-1.2
automake                    1:1.16.1-4
autoconf                    2.69-11
bash            5.0-4
Comment 1 Tom Tromey 2019-12-18 15:06:16 UTC
"./configure" is currently broken.
We're debating what to do about this on the gdb@ list.
Feel free to weigh in there if you have an opinion.
Comment 2 Tom Tromey 2019-12-18 15:14:52 UTC
I found an earlier dup.

*** This bug has been marked as a duplicate of bug 24729 ***