Bug 25016 - Test-case failures for -pie
Summary: Test-case failures for -pie
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 8.3
: P2 normal
Target Milestone: 8.3.1
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 25013 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-18 20:45 UTC by Tom de Vries
Modified: 2019-10-13 13:10 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom de Vries 2019-09-18 20:45:37 UTC
Recent versions of Ubuntu and Debian default GCC to enable pie.

In dump.exp, pie will causes addresses to be out of range for IHEX.

In break-interp.exp, pie is explicitly set for some tests and assumed to be disabled for the remainder.
Comment 1 cvs-commit@gcc.gnu.org 2019-09-18 20:49:52 UTC
The gdb-8.3-branch branch has been updated by Tom de Vries <vries@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=3d80b2e754ffe925f44b5de71d799debfb7e82a0

commit 3d80b2e754ffe925f44b5de71d799debfb7e82a0
Author: Tom de Vries <tdevries@suse.de>
Date:   Wed Sep 18 22:48:57 2019 +0200

    Update ChangeLog entry of commit 3b752ac2e6 and mention PR testsuite/25016
Comment 2 Tom de Vries 2019-09-18 20:50:27 UTC
Patch backported, marking resolved-fixed.
Comment 3 Alan Hayward 2019-09-19 14:37:22 UTC
*** Bug 25013 has been marked as a duplicate of this bug. ***
Comment 4 cvs-commit@gcc.gnu.org 2019-10-13 13:10:00 UTC
The master branch has been updated by Tom de Vries <vries@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=34a7f2a4e33012a136fb42cfd1f858c6b379aa63

commit 34a7f2a4e33012a136fb42cfd1f858c6b379aa63
Author: Tom de Vries <tdevries@suse.de>
Date:   Sun Oct 13 15:09:09 2019 +0200

    Mention PR testsuite/25016 in ChangeLog entry
    
    [ Port of gdb-8.3-branch commit 3d80b2e754f "Update ChangeLog entry of commit
    3b752ac2e6 and mention PR testsuite/25016". ]