Bug 20809 - mips sim build fails for r3900 cpus
Summary: mips sim build fails for r3900 cpus
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: sim (show other bugs)
Version: 7.12
: P2 normal
Target Milestone: 7.12.1
Assignee: Mike Frysinger
URL: https://sourceware.org/ml/gdb/2016-11...
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-12 06:01 IST by Mike Frysinger
Modified: 2016-11-12 06:01 IST (History)
1 user (show)

See Also:
Host:
Target: mipstx39-rtems4.12
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Frysinger 2016-11-12 06:01:05 IST
example build failure:
https://sourceware.org/ml/gdb/2016-11/msg00017.html
/home/joel/rtems-4.11-work/rtems-source-builder/rtems/sources/b-mips/sim/mips/../../../gdb-7.12/sim/mips/mips.igen:1254: undefined reference to `check_u64'

this is due to the r3900 cpus lacking markings for the check_u64 in the igen code.

should be fixed by:
https://sourceware.org/ml/gdb-patches/2016-11/msg00287.html
Comment 1 Mike Frysinger 2016-11-12 06:01:33 IST
fix pushed to master & 7.12 branch