Bug 20808 - mips sim build fails due to undefined SD/CPU variables
Summary: mips sim build fails due to undefined SD/CPU variables
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: sim (show other bugs)
Version: 7.12
: P2 normal
Target Milestone: 7.12.1
Assignee: Mike Frysinger
URL: https://sourceware.org/ml/gdb/2016-11...
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-12 05:58 IST by Mike Frysinger
Modified: 2016-11-12 06:01 IST (History)
1 user (show)

See Also:
Host:
Target: mipstx39-rtems4.12
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Frysinger 2016-11-12 05:58:39 IST
example build failure:
https://sourceware.org/ml/gdb/2016-11/msg00013.html
../../../gdb-7.12/sim/mips/dv-tx3904cpu.c: In function ‘deliver_tx3904cpu_interrupt’:
../../../gdb-7.12/sim/mips/sim-main.h:679:64: error: ‘SD’ undeclared (first use in this function)
 #define SignalExceptionNMIReset()            signal_exception (SD, CPU, cia, NMIReset)

this was due to a cleanup of global state in commit d47f5b30d8481272e9480118bdcb283690070349

should be fixed by:
https://sourceware.org/ml/gdb-patches/2016-11/msg00288.html
Comment 1 Mike Frysinger 2016-11-12 05:58:53 IST
fix pushed to master & 7.12 branch