Bug 17489 - dlltool --kill-at documentation wrong
Summary: dlltool --kill-at documentation wrong
Status: RESOLVED FIXED
Alias: None
Product: binutils
Classification: Unclassified
Component: binutils (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-15 15:58 UTC by Daniel C. Klauer
Modified: 2015-01-05 13:55 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Suggestion for better --kill-at dlltool documentation (522 bytes, patch)
2014-12-31 01:02 UTC, Daniel C. Klauer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel C. Klauer 2014-10-15 15:58:13 UTC
The last sentence in the description for dlltool's -k (--kill-at) command line option in binutils/doc/binutils.texi seems to be wrong:

> [...] These numbers are
> called ordinal numbers and they represent another way of accessing the
> function in a DLL, other than by name.

I think --kill-at refers to the @<n> suffix used in stdcall function name mangling, not the ordinal numbers.
Comment 1 Nick Clifton 2014-10-29 16:18:19 UTC
Hi Daniel,

  Do you have a suggestion for a correct version of that last sentance ?

Cheers
  Nick
Comment 2 Daniel C. Klauer 2014-12-31 01:02:32 UTC
Created attachment 8036 [details]
Suggestion for better --kill-at dlltool documentation

Ok; here's a patch for the relevant part of the docs.
Comment 3 Nick Clifton 2015-01-05 09:44:39 UTC
Hi Daniel,

  Thanks for the patch.  I have applied it, together with this changelog entry:

Cheers
  Nick

binutils/ChangeLog
2015-01-05  Daniel Klauer  <daniel.c.klauer@web.de>

	PR binutils/17489
	* doc/binutils.texi (dlltool): Correct description of --kill-at
	option.
Comment 4 cvs-commit@gcc.gnu.org 2015-01-05 13:55:46 UTC
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  82b1b41bcdc6d01fdbd94b246e24a8a8f8c2bddd (commit)
       via  c1724c7fd39d85ccc1f94a0cd7bc25b19aa43ffd (commit)
      from  f8ed3ac5f2600f037bff4ba01e6c92257d4a4fae (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=82b1b41bcdc6d01fdbd94b246e24a8a8f8c2bddd

commit 82b1b41bcdc6d01fdbd94b246e24a8a8f8c2bddd
Author: Nick Clifton <nickc@redhat.com>
Date:   Mon Jan 5 13:54:22 2015 +0000

    More fixes for invalid memory accesses triggered by fuzzed binaries.
    
    	PR binutils/17531
    	* dwarf.c (alloc_num_debug_info_entries): New variable.
    	(process_debug_info): Set it.  Use it to avoid displaying
    	attributes for which there is no info.
    	(display_debug_abbrev): Check that the debug_info_entry index is
    	valid before using it.
    	(display_loc_list_dwo): Likewise.
    	(process_cu_tu_index): Add range check for an overlarge dw_sect
    	value.
    	(free_debug_memory): Reset alloc_num_debug_info_entries.
    	* readelf.c (slurp_ia64_unwind_table): Warn if the reloc could not
    	be indentified.
    	(dynamic_section_mips_val): Warn if the timestamp is invalid.
    	(print_mips_got_entry): Add a data_end parameter.  Warn if a read
    	would go beyond the end of the data, and return an error value.
    	(process_mips_specific): Do not read options from beyond the end
    	of the section.
    	Correct code to display optional data at the end of an option.
    	Warn if there are too many GOT symbols.
    	Update calls to print_mips_got_entry, and handle error returns.

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=c1724c7fd39d85ccc1f94a0cd7bc25b19aa43ffd

commit c1724c7fd39d85ccc1f94a0cd7bc25b19aa43ffd
Author: Daniel Klauer <daniel.c.klauer@web.de>
Date:   Mon Jan 5 09:41:48 2015 +0000

    Corrects the description of the --kill-at option of dlltool.
    
    	PR binutils/17489
    	* doc/binutils.texi (dlltool): Correct description of --kill-at
    	option.

-----------------------------------------------------------------------

Summary of changes:
 binutils/ChangeLog         |   29 ++++++++++++
 binutils/doc/binutils.texi |   12 +++--
 binutils/dwarf.c           |  107 +++++++++++++++++++++++++++++++-------------
 binutils/dwarf.h           |    8 ++--
 binutils/readelf.c         |  100 +++++++++++++++++++++++++++++++---------
 5 files changed, 194 insertions(+), 62 deletions(-)