Bug 17456 - 7.8 crash regression for annota1.exp w/vDSO debuginfo
Summary: 7.8 crash regression for annota1.exp w/vDSO debuginfo
Status: RESOLVED DUPLICATE of bug 17472
Alias: None
Product: gdb
Classification: Unclassified
Component: cli (show other bugs)
Version: 7.8
: P2 normal
Target Milestone: 7.8
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-05 14:05 UTC by Jan Kratochvil
Modified: 2014-10-10 08:00 UTC (History)
3 users (show)

See Also:
Host: x86_64-linux-gnu
Target: x86_64-linux-gnu
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kratochvil 2014-10-05 14:05:43 UTC
https://sourceware.org/ml/gdb-patches/2014-10/msg00082.html

329ea57934a9d4b250a0b417af1ec47bc2d0ceb6 is the first bad commit
commit 329ea57934a9d4b250a0b417af1ec47bc2d0ceb6
Author: Pedro Alves <palves@redhat.com>
Date:   Thu May 29 19:58:57 2014 +0100

    enable target async by default; separate MI and target notions of async

CFLAGS=-g ./configure --without-guile --with-separate-debug-dir=/usr/lib/debug;make;cd gdb/testsuite;make
site.exp;i=0;while runtest gdb.base/annota1.exp;! grep 'called with no handler' gdb.log ;do i=$[$i+1];echo
-----------$i;done

Starting program: .../gdb/testsuite/gdb.base/annota1 ^M
warning: section  not found in /usr/lib/debug/lib/modules/3.16.3-200.fc20.x86_64/vdso/vdso64.so.debug^M
[...]
FAIL: gdb.base/annota1.exp: run until main breakpoint (timeout)
[...]
readline: readline_callback_read_char() called with no handler!^M
ERROR: Process no longer exists

kernel-debuginfo-3.16.3-200.fc20.x86_64

#0  in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  in __GI_abort () at abort.c:89
#2  in rl_callback_read_char () at callback.c:116
#3  in rl_callback_read_char_wrapper (client_data=0x0) at event-top.c:167
#4  in stdin_event_handler (error=0, client_data=0x0) at event-top.c:373
#5  in handle_file_event (data=...) at event-loop.c:763
#6  in process_event () at event-loop.c:340
#7  in gdb_do_one_event () at event-loop.c:361
#8  in start_event_loop () at event-loop.c:429
#9  in cli_command_loop (data=0x0) at event-top.c:182
#10 in current_interp_command_loop () at interps.c:318
#11 in captured_command_loop (data=0x0) at main.c:323
#12 in catch_errors (func=0x6133a6 <captured_command_loop>, func_args=0x0, errstring=0x902525 "", mask=RETURN_MASK_ALL)
at exceptions.c:237
#13 in captured_main (data=0x7fff7eb43bd0) at main.c:1151
#14 in catch_errors (func=0x6137be <captured_main>, func_args=0x7fff7eb43bd0, errstring=0x902525 "",
mask=RETURN_MASK_ALL) at exceptions.c:237
#15 in gdb_main (args=0x7fff7eb43bd0) at main.c:1159
#16 in main (argc=5, argv=0x7fff7eb43cd8) at gdb.c:32

That file /usr/lib/debug/lib/modules/3.16.3-200.fc20.x86_64/vdso/vdso64.so.debug is required for the crash
reproducibility.
Comment 1 Jan Kratochvil 2014-10-05 14:13:55 UTC
*** Bug 17300 has been marked as a duplicate of this bug. ***
Comment 2 Jan Kratochvil 2014-10-10 08:00:11 UTC
Duplicate.

*** This bug has been marked as a duplicate of bug 17472 ***