Bug 17367 - computation of guild path wrong when pkg-config script supplied as arg to --with-guile
Summary: computation of guild path wrong when pkg-config script supplied as arg to --w...
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: guile (show other bugs)
Version: HEAD
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-10 04:06 UTC by Doug Evans
Modified: 2014-10-29 19:48 UTC (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Evans 2014-09-10 04:06:52 UTC
Guile 2.2 now compiles to ELF files, and I was noticing gdb complaining when starting up.

Exception caught while booting Guile.
Error in function "load-thunk-from-memory":
not an ELF file
./gdb: warning: Could not complete Guile gdb module initialization from:
/hack/gnu/sourceware/gdb-guile/b-sigchld-prep-git-guile-gc74/gdb/data-directory/guile/gdb/boot.scm.

I traced this to the wrong guild program being used.
guild should come from the specified guile distribution,
but /bin/guild was being used instead (which is guile 2.0).
Comment 1 Doug Evans 2014-09-10 04:09:32 UTC
For reference sake, here's the pkg-config script.

#! /bin/sh                                                                                                                                                       

BDWGC=/path/to/boehm-git/release-7_4/rel
GUILE=/path/to/guile/git/rel

case "$1" in
--exists) exit 0 ;;
--cflags) echo "-pthread -I$BDWGC/include -I$GUILE/include/guile/2.2" ; exit 0 ;;
--libs) echo "-Wl,-rpath,$BDWGC/lib -L$BDWGC/lib -Wl,-rpath,$GUILE/lib -L$GUILE/lib -lguile-2.2 -lgc" ; exit 0 ;;
--variable)
  case "$2" in
  guild) echo "$GUILE/bin/guild" ; exit 0 ;;
  exec_prefix) echo "$GUILE" ; exit 0 ;;
  *) echo "bad arg" >&2 ; exit 1 ;;
  esac
  ;;
*) echo "bad arg" >&2 ; exit 1 ;;
esac

It's mildly hacky in that it doesn't check the supplied guile version (which is the last parameter passed), but it works.
Comment 2 cvs-commit@gcc.gnu.org 2014-09-10 04:20:24 UTC
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  d342a0da4fa83b680426511a7d0e1b1e299c63b8 (commit)
      from  b4a3d263b07508de083928823aee72699e59afc0 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=d342a0da4fa83b680426511a7d0e1b1e299c63b8

commit d342a0da4fa83b680426511a7d0e1b1e299c63b8
Author: Doug Evans <xdje42@gmail.com>
Date:   Tue Sep 9 21:18:25 2014 -0700

    PR guile/17367
    
    gdb/ChangeLog:
    
    	* acinclude.m4 (GDB_GUILE_PROGRAM_NAMES): Pass guile version as
    	last parameter to pkg-config, not first.
    	* configure.ac: Pass --with-guile provided pkg-config path to
    	GDB_GUILE_PROGRAM_NAMES.
    	* configure: Regenerate.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog    |    9 +++++++++
 gdb/acinclude.m4 |    4 ++--
 gdb/configure    |   38 ++++++++++++++++++++++++++++++++++++--
 gdb/configure.ac |   14 +++++++++++---
 4 files changed, 58 insertions(+), 7 deletions(-)
Comment 3 cvs-commit@gcc.gnu.org 2014-09-10 05:14:43 UTC
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, gdb-7.8-branch has been updated
       via  14075b38b1f43d03e0e35a04a7f5cdb5774ba5cf (commit)
      from  0df33300929f9b54ddcf040f9b1fe69c1a88304b (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=14075b38b1f43d03e0e35a04a7f5cdb5774ba5cf

commit 14075b38b1f43d03e0e35a04a7f5cdb5774ba5cf
Author: Doug Evans <xdje42@gmail.com>
Date:   Tue Sep 9 22:06:35 2014 -0700

    PR guile/17367
    
    gdb/ChangeLog:
    
    	* acinclude.m4 (GDB_GUILE_PROGRAM_NAMES): Pass guile version as
    	last parameter to pkg-config, not first.
    	* configure.ac: Pass --with-guile provided pkg-config path to
    	GDB_GUILE_PROGRAM_NAMES.
    	* configure: Regenerate.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog    |    9 +++++++++
 gdb/acinclude.m4 |    4 ++--
 gdb/configure    |   38 ++++++++++++++++++++++++++++++++++++--
 gdb/configure.ac |   14 +++++++++++---
 4 files changed, 58 insertions(+), 7 deletions(-)
Comment 4 Doug Evans 2014-09-11 16:01:00 UTC
patch committed to both trunk and 7.8 branch
Comment 5 cvs-commit@gcc.gnu.org 2014-10-29 19:48:15 UTC
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The annotated tag, gdb-7.8.1-release has been created
        at  60cd8f8e7f38daf7d59e82b9fb3b8840a3a714c9 (tag)
   tagging  21de41c04a26bb04f2e827d35fd48c991fa991b1 (commit)
  replaces  gdb-7.8-release
 tagged by  Joel Brobecker
        on  Wed Oct 29 12:47:08 2014 -0700

- Log -----------------------------------------------------------------
GDB 7.8.1 Release.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEABECAAYFAlRRRDwACgkQku2wS/8yXPNA3gCgmaBkksiuRbHoYAudWcZYwiJ4
upIAoI2vGr/6e6CNHxIinVYQ2IJCY/4V
=wgXR
-----END PGP SIGNATURE-----

Doug Evans (3):
      Fix for PR 17247: Block SIGCHLD while initializing Guile.
      PR guile/17367
      PR python/17364

Eli Zaretskii (1):
      Avoid compiler warnings about incomplete parameter types.

GDB Administrator (92):
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in
      Automatic date update in version.in

Jan Kratochvil (4):
      Fix incorrect placement of two Intel gdb/NEWS items
      Fix 'gcore' with exited threads
      Fix crash on Python frame filters with unreadable arg
      Fix regression for Linux vDSO in GDB (PR gdb/17407).

Joel Brobecker (5):
      Document the GDB 7.8 release in gdb/ChangeLog
      Bump GDB version number to 7.8.0.DATE-cvs.
      Add "frame.h" #include in gdbarch.h.
      state->dr_control_mirror == 0 failed assertion in gdbserver on Windows XP
      Set GDB version number to 7.8.1.

Pedro Alves (9):
      testsuite: refactor spawn and wait for attach
      gdb/17347 - Regression: GDB stopped on run with attached process
      Aarch64: Make CPSR a 32-bit register again in the target description
      Make common code handle target_terminal_* idempotency
      PR gdb/17472: With annotations, input while executing in the foreground crashes readline/GDB
      PR gdb/17300: Input after "c -a" crashes readline/GDB
      PR gdb/17471: Repeating a background command makes it foreground
      PR python/17372 - Python hangs when displaying help()
      PR 17408 - assertion failure in switch_back_to_stepped_thread

Siva Chandra (1):
      Fix xmethod Python so that it works with Python3.

Yao Qi (2):
      Fix build/17104
      Remove workaround to libbabeltrace 1.1.0 issue

-----------------------------------------------------------------------