Bug 17345 - babeltrace (1.1.2 and later) complains about the ctf data generated by GDB
Summary: babeltrace (1.1.2 and later) complains about the ctf data generated by GDB
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: 7.8
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-03 02:07 IST by Yao Qi
Modified: 2014-09-03 02:08 IST (History)
0 users

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yao Qi 2014-09-03 02:07:09 IST
Recent babeltrace (1.1.2 and later) complains about the ctf data generated by GDB:

 (gdb) target ctf .../gdb/testsuite/gdb.trace/actions.ctf
 [error] Invalid CTF stream: content size is smaller than packet headers.
 [error] Stream index creation error.
 [error] Open file stream error.

This is caused by a workaround we added for babeltrace 1.1.0.  Since babeltrace 1.1.2 was released for some times, we remove the workaround in GDB and users can build GDB with 1.1.2 or later.
Comment 1 Yao Qi 2014-09-03 02:08:09 IST
This patch https://sourceware.org/ml/gdb-patches/2014-08/msg00460.html is committed to mainline and 7.8 branch.