Bug 17046 - Will not build on OS X 10.10 Yosemite.
Summary: Will not build on OS X 10.10 Yosemite.
Status: RESOLVED FIXED
Alias: None
Product: gdb
Classification: Unclassified
Component: gdb (show other bugs)
Version: 7.7
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-10 14:58 UTC by adaminsull
Modified: 2015-01-12 17:22 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description adaminsull 2014-06-10 14:58:51 UTC
I have used MacPorts to try to update this but it failed with "darwin-nat.c:45:10: fatal error: 'machine/setjmp.h' file not found". I found out that it is because in the code for darwin-nat.c says "<machine/setjmp.h>" when it should be "<setjmp.h>". I just wanted to make this report so it can be fixed for other users.
Comment 1 James Clarke 2014-09-15 21:34:51 UTC
Patch submitted to the mailing list: https://sourceware.org/ml/gdb-patches/2014-09/msg00509.html
Comment 2 cvs-commit@gcc.gnu.org 2015-01-12 17:19:08 UTC
The master branch has been updated by Joel Brobecker <brobecke@sourceware.org>:

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=4ac15b59f2f506ff0ad59f148275cd7406b8d765

commit 4ac15b59f2f506ff0ad59f148275cd7406b8d765
Author: James Clarke <jrtc27@jrtc27.com>
Date:   Mon Jan 12 21:13:54 2015 +0400

    [darwin/gdb] Use <setjmp.h> instead of <machine/setjmp.h>
    
    The `machine/setjmp.h' header is no longer present on OS X 10.10, and is
    non-standard. Instead, `darwin-nat.c' should be using the standard
    `setjmp.h' header.
    
    gdb/ChangeLog:
    
    2015-01-12  James Clarke  <jrtc27@jrtc27.com>  (tiny patch)
    
    	PR gdb/17046
    	* darwin-nat.c: Replace <machine/setjmp.h> #include by
    	<setjmp.h> #include.
Comment 3 Joel Brobecker 2015-01-12 17:22:26 UTC
should now be fixed. Closing.