Bug 1418 - A rapidly exec'ing process on attach causes stack trace
Summary: A rapidly exec'ing process on attach causes stack trace
Status: RESOLVED FIXED
Alias: None
Product: frysk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
: P1 normal
Target Milestone: ---
Assignee: Andrew Cagney
URL:
Keywords:
: 1500 1988 (view as bug list)
Depends on: 1500 1988
Blocks: 1586 1654
  Show dependency treegraph
 
Reported: 2005-10-04 21:43 IST by Phil Muldoon
Modified: 2006-12-08 18:57 IST (History)
1 user (show)

See Also:
Host:
Target:
Build:
Last reconfirmed:


Attachments
Very Simple Exec bomb (1.12 KB, text/plain)
2005-10-04 21:50 IST, Phil Muldoon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Muldoon 2005-10-04 21:43:26 IST
1) Create a simple exec bomb (a program that execs itself every 1 or so seconds)
2) Attach to that process

Stack trace produced:

Exception in thread "Thread-1" java.lang.RuntimeException:
Linux[Task,id={TaskId,29203},proc=[Proc,id={ProcId,29203},state=[runningState]],state=[unattachedState]]
in state "unattached" did not handle
[Execed[TaskEvent,taskLinux[Task,id={TaskId,29203},proc=[Proc,id={ProcId,29203},state=[runningState]],state=[unattachedState]]]]
   at frysk.proc.State.unhandled(java.lang.Object, java.lang.String)
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/State.java:67)
   at frysk.proc.State.unhandled(java.lang.Object, frysk.event.Event)
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/State.java:58)
   at frysk.proc.TaskState.process(frysk.proc.Task, frysk.proc.TaskEvent$Execed)
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/TaskState.java:98)
   at frysk.proc.TaskEvent$Execed.execute()
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/TaskEvent.java:133)
   at frysk.event.EventLoop.runPending()
(/home/pmuldoon/workspace/frysk-gui/frysk/event/EventLoop.java:201)
   at frysk.event.EventLoop.run()
(/home/pmuldoon/workspace/frysk-gui/frysk/event/EventLoop.java:255)
   at frysk.gui.FryskGui$2.run()
(/home/pmuldoon/workspace/frysk-gui/frysk/gui/FryskGui.java:178)
   at java.lang.Thread.run() (/usr/lib/libgcj.so.6.0.0)
Comment 1 Phil Muldoon 2005-10-04 21:50:11 IST
Created attachment 684 [details]
Very Simple Exec bomb
Comment 2 Phil Muldoon 2005-10-05 18:59:00 IST
It seems that this just occurs at any time. The rapid Exec exposes it more
rapidly than in normal usage. But in the sceanrio where an observer is added to
"normal" process (ie ones that do not magnify troubling behaviour on a larger
scale) these stack traces occur then too.
Comment 3 Phil Muldoon 2005-10-18 20:45:51 IST
Currently there does not have to be an exec observer attached to the PID for
this to occur now (it occurs just on startup)

Exception in thread "Thread-2" java.lang.RuntimeException:
Linux{frysk.proc.LinuxTask@5b63c60,id={TaskId,9455},proc={frysk.proc.LinuxProc@5b2c820,id={ProcId,9455},state=running},state=unattached}
in state "unattached" did not handle PerformExeced
   at frysk.proc.State.unhandled(java.lang.Object, java.lang.String)
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/State.java:70)
   at frysk.proc.TaskState.processPerformExeced(frysk.proc.Task)
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/TaskState.java:106)
   at frysk.proc.Task$19.execute()
(/home/pmuldoon/workspace/frysk-gui/frysk/proc/Task.java:442)
   at frysk.event.EventLoop.runEventLoop(boolean)
(/home/pmuldoon/workspace/frysk-gui/frysk/event/EventLoop.java:290)
   at frysk.event.EventLoop.run()
(/home/pmuldoon/workspace/frysk-gui/frysk/event/EventLoop.java:384)
   at frysk.gui.FryskGui$3.run()
(/home/pmuldoon/workspace/frysk-gui/frysk/gui/FryskGui.java:189)
   at java.lang.Thread.run() (/usr/lib/libgcj.so.6.0.0)
Comment 4 Andrew Cagney 2005-12-11 16:58:13 IST
*** Bug 1500 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Cagney 2005-12-11 16:59:29 IST
*** Bug 1988 has been marked as a duplicate of this bug. ***
Comment 6 Stan Cox 2006-01-31 18:57:33 IST
The exec observer now works okay.
Changed Proc.java.