side_controls_unit vs. tk interface

Stan Shebs shebs@shebs.cnchost.com
Fri Oct 6 09:18:00 GMT 2000


Jim Kingdon wrote:
> 
> > The theory is good, but is there some reason the test can't go into
> > REQUIRE_UNIT?
> 
> do_distance, do_occupant, and do_recenter call REQUIRE_UNIT but don't
> want to call side_controls_unit.

OK then, we can either make a different macro for those three or just
opencode it for them, along with a note as to why they're different.  We're
always going to have more commands restricted to a player's own units
than can be done on anybody's unit, so flipping the default case seems
more efficient here.

Stan


More information about the Xconq7 mailing list