[PATCH v6 1/7] aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`
Karl Meakin via Sourceware Forge
forge-bot@forge-test.rdfm.org
Wed Oct 8 16:41:30 GMT 2025
From: Karl Meakin <karl.meakin@arm.com>
gcc/ChangeLog:
* config/aarch64/aarch64-builtins.cc (ENTRY): Rename to ...
(DEF_SIMD_TYPE): Here.
* config/aarch64/aarch64-builtins.h (ENTRY): Likewise.
(DEF_SIMD_TYPE): Likewise.
* config/aarch64/aarch64-simd-builtin-types.def (ENTRY): Likewise.
(DEF_SIMD_TYPE): Likewise.
* config/aarch64/aarch64-sve-builtins.h (ENTRY): Likewise.
(DEF_SIMD_TYPE): Likewise.
---
gcc/config/aarch64/aarch64-builtins.cc | 4 +-
gcc/config/aarch64/aarch64-builtins.h | 3 +-
.../aarch64/aarch64-simd-builtin-types.def | 78 ++++++++++---------
gcc/config/aarch64/aarch64-sve-builtins.h | 3 +-
4 files changed, 45 insertions(+), 43 deletions(-)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: v6-0001-aarch64-Rename-ENTRY-to-DEF_SIMD_TYPE.patch
Type: text/x-patch
Size: 5382 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/test-list/attachments/20251008/a4c2f3f5/attachment.bin>
More information about the Test-list
mailing list