[PATCH v6 0/7] aarch64: intrinsics refactors

Karl Meakin via Sourceware Forge forge-bot@forge-test.rdfm.org
Thu Oct 16 12:13:01 GMT 2025


Hi gcc-patches mailing list,
Karl Meakin <karmea01@sourceware.org> has requested that the following forgejo pull request
be published on the mailing list.

Created on: 2025-10-02 16:30:31+00:00
Latest update: 2025-10-16 12:12:50+00:00
Changes: 9 changed files, 270 additions, 171 deletions
Head revision: karmea01/gcc-TEST ref km/aarch64-intrinsics-refactors/v1 commit 18cc0ce932f2ace652a330137e63b2761be87873
Base revision: gcc/gcc-TEST ref trunk commit c62f3e81a0b0ec7a5bec993ce3fe137ed182233c r16-4442-gc62f3e81a0b0ec
Merge base: c62f3e81a0b0ec7a5bec993ce3fe137ed182233c
Full diff url: https://forge.sourceware.org/gcc/gcc-TEST/pulls/90.diff
Discussion:  https://forge.sourceware.org/gcc/gcc-TEST/pulls/90
Requested Reviewers:


Minor refactors and documentation improvements. NFCI

Testing done: `make check-gcc` and `make check-target`

ChangeLog:
* v1: Initial revision
* v2:
  * Add "aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`"
  * Squash "aarch64: Delete duplicate enum aarch64_simd_type definition" into "aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`"
  * Add "aarch64: Make `NUM_VECTOR_TYPES` an enum member"
  * Add "aarch64: Use shifts in `aarch64_type_qualifiers` enum "


Changed files:
- M: gcc/config/aarch64/aarch64-builtins.cc
- M: gcc/config/aarch64/aarch64-builtins.h
- M: gcc/config/aarch64/aarch64-neon-sve-bridge-builtins.def
- M: gcc/config/aarch64/aarch64-simd-builtin-types.def
- M: gcc/config/aarch64/aarch64-sve-builtins-base.def
- M: gcc/config/aarch64/aarch64-sve-builtins-sme.def
- M: gcc/config/aarch64/aarch64-sve-builtins.cc
- M: gcc/config/aarch64/aarch64-sve-builtins.def
- M: gcc/config/aarch64/aarch64-sve-builtins.h


Karl Meakin (7):
  aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`
  aarch64: Document `DEF_*` macros
  aarch64: Define `DEF_SVE_TYPE_SUFFIX` in terms of
    `DEF_SVE_NEON_TYPE_SUFFIX`
  aarch64: Use variadic arguments
  aarch64: Reformat array initializers
  aarch64: Make `NUM_VECTOR_TYPES` an enum member
  aarch64: Use shifts in `aarch64_type_qualifiers` enum

 gcc/config/aarch64/aarch64-builtins.cc        |  12 +-
 gcc/config/aarch64/aarch64-builtins.h         |  38 ++--
 .../aarch64-neon-sve-bridge-builtins.def      |   4 +-
 .../aarch64/aarch64-simd-builtin-types.def    |  80 +++++----
 .../aarch64/aarch64-sve-builtins-base.def     |  22 +++
 .../aarch64/aarch64-sve-builtins-sme.def      |  24 ++-
 gcc/config/aarch64/aarch64-sve-builtins.cc    | 169 +++++++++++-------
 gcc/config/aarch64/aarch64-sve-builtins.def   |  51 ++++--
 gcc/config/aarch64/aarch64-sve-builtins.h     |  19 +-
 9 files changed, 259 insertions(+), 160 deletions(-)

Range-diff against v5:
1:  6eb69a5d29b = 1:  6eb69a5d29b aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`
2:  37a4c495628 = 2:  37a4c495628 aarch64: Document `DEF_*` macros
3:  784db6f1a2b = 3:  784db6f1a2b aarch64: Define `DEF_SVE_TYPE_SUFFIX` in terms of `DEF_SVE_NEON_TYPE_SUFFIX`
4:  df495365d55 = 4:  df495365d55 aarch64: Use variadic arguments
5:  b154a8555ef ! 5:  de772c33d20 aarch64: Reformat array initializers
    @@ gcc/config/aarch64/aarch64-builtins.cc: const char *aarch64_scalar_builtin_types
     +  {/* .type       = */ NAME,			   \
     +   /* .name       = */ "__" #NAME,		   \
     +   /* .mangle     = */ #LEN "__" #NAME,		   \
    -+   /* .mode       = */ NAME_##MODE##mode,	   \
    ++   /* .mode       = */ MODE##mode,		   \
     +   /* .qualifiers = */ qualifier_##QUALIFIERS},
      const struct aarch64_simd_type_info aarch64_simd_types[] = {
      #include "aarch64-simd-builtin-types.def"
6:  3b76587a8c3 = 6:  9cb8e1e3c16 aarch64: Make `NUM_VECTOR_TYPES` an enum member
7:  7788c58ec1f = 7:  18cc0ce932f aarch64: Use shifts in `aarch64_type_qualifiers` enum
-- 
2.50.1



More information about the Test-list mailing list