[PATCH v4 0/7] aarch64: intrinsics refactors

Karl Meakin via Sourceware Forge forge-bot@forge-test.rdfm.org
Thu Oct 9 09:35:56 GMT 2025


Hi gcc-patches mailing list,
Karl Meakin <karmea01@sourceware.org> has requested that the following forgejo pull request
be published on the mailing list.

Created on: 2025-10-02 16:30:31+00:00
Latest update: 2025-10-09 09:35:12+00:00
Changes: 9 changed files, 270 additions, 171 deletions
Head revision: karmea01/gcc-TEST ref km/aarch64-intrinsics-refactors/v1 commit 87223f9e64f027f3b9e7e81aac3e78af1ee3d03d
Base revision: gcc/gcc-TEST ref trunk commit 50959e53e40ae087ee7bdbce7229b4b8b3cd1bb6 r16-4308-g50959e53e40ae0
Merge base: 50959e53e40ae087ee7bdbce7229b4b8b3cd1bb6
Full diff url: https://forge.sourceware.org/gcc/gcc-TEST/pulls/90.diff
Discussion:  https://forge.sourceware.org/gcc/gcc-TEST/pulls/90
Requested Reviewers:


Minor refactors and documentation improvements. NFCI

Testing done: `make check-gcc` and `make check-target`

ChangeLog:
* v1: Initial revision
* v2:
  * Add "aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`"
  * Squash "aarch64: Delete duplicate enum aarch64_simd_type definition" into "aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`"
  * Add "aarch64: Make `NUM_VECTOR_TYPES` an enum member"
  * Add "aarch64: Use shifts in `aarch64_type_qualifiers` enum "


Changed files:
- M: gcc/config/aarch64/aarch64-builtins.cc
- M: gcc/config/aarch64/aarch64-builtins.h
- M: gcc/config/aarch64/aarch64-neon-sve-bridge-builtins.def
- M: gcc/config/aarch64/aarch64-simd-builtin-types.def
- M: gcc/config/aarch64/aarch64-sve-builtins-base.def
- M: gcc/config/aarch64/aarch64-sve-builtins-sme.def
- M: gcc/config/aarch64/aarch64-sve-builtins.cc
- M: gcc/config/aarch64/aarch64-sve-builtins.def
- M: gcc/config/aarch64/aarch64-sve-builtins.h


Karl Meakin (7):
  aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`
  aarch64: Document `DEF_*` macros
  aarch64: Define `DEF_SVE_TYPE_SUFFIX` in terms of
    `DEF_SVE_NEON_TYPE_SUFFIX`
  aarch64: Use variadic arguments
  aarch64: Reformat array initializers
  aarch64: Make `NUM_VECTOR_TYPES` an enum member
  aarch64: Use shifts in `aarch64_type_qualifiers` enum

 gcc/config/aarch64/aarch64-builtins.cc        |  12 +-
 gcc/config/aarch64/aarch64-builtins.h         |  38 ++--
 .../aarch64-neon-sve-bridge-builtins.def      |   4 +-
 .../aarch64/aarch64-simd-builtin-types.def    |  80 +++++----
 .../aarch64/aarch64-sve-builtins-base.def     |  22 +++
 .../aarch64/aarch64-sve-builtins-sme.def      |  24 ++-
 gcc/config/aarch64/aarch64-sve-builtins.cc    | 169 +++++++++++-------
 gcc/config/aarch64/aarch64-sve-builtins.def   |  51 ++++--
 gcc/config/aarch64/aarch64-sve-builtins.h     |  19 +-
 9 files changed, 259 insertions(+), 160 deletions(-)

Range-diff against v3:
1:  0d0d87d770a = 1:  93f345b6063 aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`
2:  1b6b4fabfa3 = 2:  5be1d7fb596 aarch64: Document `DEF_*` macros
3:  7600531028c = 3:  1cd5158d8fc aarch64: Define `DEF_SVE_TYPE_SUFFIX` in terms of `DEF_SVE_NEON_TYPE_SUFFIX`
4:  75359483811 = 4:  498933810bc aarch64: Use variadic arguments
5:  7f8af845c5b = 5:  a811c1d9ee2 aarch64: Reformat array initializers
6:  a289a37dfdd = 6:  ccaa85a9b59 aarch64: Make `NUM_VECTOR_TYPES` an enum member
7:  d42efe5e9fe = 7:  87223f9e64f aarch64: Use shifts in `aarch64_type_qualifiers` enum
-- 
2.50.1



More information about the Test-list mailing list